I've tried a for past a while to get this working and thought i'd post here, i hope this is the right section. Ive been running an ALFA AWUS036H on my Thinkpad X22 and HP 6735s and all was fine on both systems (in both BT3 & BT4) until I was given a brand new Belkin N1 PCMCIA Card [F5D8011 Ver2010uk] and wanted to use it for when i need mobility for the net instead of the ALFA for power (injection/monitoring).

I have tried to install its win drivers using ndiswrapper and still no luck. To save some time I thought i post some info from the system

Code:
lspci:
00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 02)
00:01.0 PCI bridge: Intel Corporation 82830 830 Chipset AGP Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801CA/CAM USB Controller #3 (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 41)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
02:03.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
02:03.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
02:05.0 Communication controller: Agere Systems WinModem 56k (rev 01)
02:08.0 Ethernet controller: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller (rev 41)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88W8361 [TopDog] 802.11n Wireless (rev 03)
Code:
lspcmcia:
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:02:03.0)
  CardBus card -- see "lspci" for more information
Socket 1 Bridge:        [yenta_cardbus]         (bus ID: 0000:02:03.1)
Code:
ifconfig -a:
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx -EDITED
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

irda0     Link encap:IrLAP  HWaddr 00:00:00:00
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:90 errors:0 dropped:0 overruns:0 frame:0
          TX packets:90 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4500 (4.5 KB)  TX bytes:4500 (4.5 KB)

wlan0     --EDITED - ALFA USB ADAPTER

wmaster0  Link encap:UNSPEC  HWaddr 00-C0-CA-27-4F-00-66-30-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I have checked up on this on google for ages, its the Marvell TopDog chipset, which differs from the version 1 and 3 which are ralink chipsets i think.

Can anyone help me with the whether this card will work with BT4 and how to get it working, Really hope someone can help or point in the right direction, thanks in advance. sorry if some of what i've put is noobish, i'm a native windows user so this has thrown me learning more about linux/BT4 out the windows for the minute because i have no clue lol