Hello!

Running nmap -O to scan my own computer i noticed it can't detect that it runs Windows 7. (shows up as Vista or Server 2008)
So i assumed that nmap is a bit older. Backtrack's Nmap is 5.00, nmap site shows 5.20 to be the latest version.
So i procedeed in running apt-get upgrade and got the following lines:

The following packages have been kept back:
nmap openvas-client openvas-libraries openvas-menu

So i have a couple of questions, if you guys can help me:

1. Why are those packages beeing kept back?
2. Is there a way to unkeep them back?
3. Should i manually install nmap 5.20 or wait for it be upgrade through the repository?

Thank you!