Hi,i have just install and update BT4 Final distro on my asus 701,i know that madwifi drivers are integrated in BT4 so i prefer to use them instead of ath5k.To do that i make the following actions:

I add the ath_pci module to the kernel:

nano /etc/modules

i add ath_pci to the end of the file.

ath_pci

then i run:

lsmod | grep ath5k

rmmod ath5k

and then i blacklist it:

echo “blacklist ath5k” | sudo tee -a /etc/modprobe.d/blacklist

after that i comment the ath_pci module in /etc/modprobe.d/blacklist:

#blacklist ath_pci

I changed the wifi interface in WICD manager from wlan0 to ath0 and i reboot the PC.After the restart i run start-network and startx commands,but when i open WICD manager it shows "no wireless netwoks available".I open Konsole and run ifconfig,here is the output;

root@bt:~# ifconfig
ath0 Link encap:Ethernet HWaddr 00:09:5B:98:E3:FD
inet6 addr: fe80::209:5bff:fe98:e3fd/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:11:252:AC:BA
inet addr:192.168.254.102 Bcast:192.168.254.255 Mask:255.255.255.0
inet6 addr: fe80::211:25ff:fed2:acba/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:38432 errors:0 dropped:0 overruns:0 frame:0
TX packets:47696 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:17134965 (16.3 Mb) TX bytes:5915094 (5.6 Mb)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

wifi0 Link encap:Ethernet HWaddr 00:09:5B:98:E3:FD
inet6 addr: fe80::209:5bff:fe98:e3fd/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:113 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:334 (334.0 b) TX bytes:5198 (5.0 Kb)
Interrupt:16 Memory:f8c40000-f8c50000

iwconfig output:

root@bt:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: 00:00:00:00:00:00
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retryff RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

On first look everything seems to be fine,but i have no wireless internet connection and when i try to use airodumb,i got the following error:

root@bt:~# airodump ath0 test
ioctl(SIOCSIWMODE) failed: Invalid argument

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211
or ARPHRD_IEEE80211_PRISM instead. Make sure RFMON is enabled:
run 'ifconfig ath0 up; iwconfig ath0 mode Monitor channel <#>'

However i find the way to make packet injection works ,using the following commands:

wlanconfig ath0 destroy

wlanconfig ath0 create wlandev wifi0 wlanmode monitor

But i can't get my WICD manager working.Obiously there is some kind of problem but i can't resolve it.Previously i used BT4 PreF with madwifi drivers ,and back then i did everything exactly the same way ,and i've never had any problems.Did i do something wrong,did i make any kind of mistake during the installation or this is some kind of bug in new BT4 Final distro.
10x in advance