Results 1 to 3 of 3

Thread: making my drivers see channels 12-14 ??

  1. #1
    Junior Member PwnStar's Avatar
    Join Date
    Jul 2008
    Posts
    34

    Default making my drivers see channels 12-14 ??

    Hello im having trouble with some wifi cracking im trying the target networks are all on channel 13 i have 2 wifi cards on my laptop a IPW3945 built in jobby and a USB f5d7050b both are working fine on wlano and wlan1. However they wont go to a channel above 11 in airmon or airodump etc.. even using the channel flags i dont get an error but it just uses channel 11.
    when i get to using aireplay-ng i get the error " WLAN0 is on channel 11, but the AP uses channel 13"

    ive traced this error back to a driver issue the drivers built into bt4 are the US version and they only have 11 wifi channels here in the UK we use channel 13 all the time for some reason ( mainly as BT defaults to that on their equipment they give free with the broadband)
    anyway i thought i had found the fix to this
    The key piece to sorting this out was adding this line to my /etc/modprobe.d/options and then re-starting my system (simple - brute force!):
    options cfg80211 ieee80211_regdom="EU"
    "iwlist wlan0 channel" previously only reported channels 1 to 11, but now shows all of them. No problems connecting to the AP now on channel 13:
    steve@steve-laptop:~$ iwlist wlan0 channel
    wlan0 13 channels in total; available frequencies :
    Channel 01 : 2.412 GHz
    Channel 02 : 2.417 GHz
    ( blah blah blah blah )
    Channel 11 : 2.462 GHz
    Channel 12 : 2.467 GHz
    Channel 13 : 2.472 GHz
    Current Frequency=2.472 GHz (Channel 13)
    i did all the above and besides the fact i have 32 channels available none of them are 12 13 and 14


    what am i doing wrong does anyone know ?? has anyone done this before to get to use channel 13 ?

    thanks for your replies please keep them simple i am a total noob

    oh forgot to add in windows both these cards work fine in the EU channel bands ..

    thought i spotted a mistake as the "EU" is in quotes in his text and i found the same instructions elsewhere without the quotes round the EU and you can also use JP but no its still only does 1-11
    Thanks to everyone who has contributed towards bt3 and all the other great tools within it, especially shamanvirtuel, spoonwpa is just awesome to a noob like me. hope you find somewhere to live.

  2. #2
    Junior Member PwnStar's Avatar
    Join Date
    Jul 2008
    Posts
    34

    Default

    jees 16 people and not one reply i guess this is a hard one .. after i edited the options file in the modprobe.r thingy i did
    modprobe -r iwl3945 then modprobe iwl3945

    still not got anywhere, its really annoying as to see the channel 13 networks obviously i can do channel 13 and windows works fine on channel 13 with the same hardware. im sure some genius will be along with the solution
    Thanks to everyone who has contributed towards bt3 and all the other great tools within it, especially shamanvirtuel, spoonwpa is just awesome to a noob like me. hope you find somewhere to live.

  3. #3
    Just burned his ISO
    Join Date
    May 2009
    Posts
    1

    Default

    Just my 5 cents,

    North America use channels 1 - 11
    Europe (ETSI) use channels 1 - 13
    Japan use channels 1 - 14

    Try setting cards region to japan?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •