Results 1 to 10 of 10

Thread: collegarsi alla propia rete wifi

  1. #1
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    9

    Default collegarsi alla propia rete wifi

    Ciao
    Sono da ieri passato a BT4.
    Non essendo molto pratico di linux, mi sono trovato subito in difficoltà.
    In paticolare volevo fare un aggiornameno di sistem sudo apt-get update.
    Ma non riesco a trovare un tool per connettermi direttamente sul mio AP wifi con chiave VPA.
    Ho scaricato dal sito di ubuntu wifi-radar, ma non funziona, in pratica parte si collega ma non riesce ad ottenee un indirizzo iP dal router.

    Come posso risolvere?
    Grazie

  2. #2
    Junior Member
    Join Date
    Dec 2009
    Posts
    25

    Default

    ciao.. per connetterti alla tua rete usa wicd lo trovi sotto la voce internet. daprima però devi attivare il network
    menu > services > network > start network..

  3. #3
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    9

    Default

    Quote Originally Posted by bt4agostino View Post
    ciao.. per connetterti alla tua rete usa wicd lo trovi sotto la voce internet. daprima però devi attivare il network
    menu > services > network > start network..
    Ok
    grazie infinite.

  4. #4
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    9

    Default

    Quote Originally Posted by bt4agostino View Post
    ciao.. per connetterti alla tua rete usa wicd lo trovi sotto la voce internet. daprima però devi attivare il network
    menu > services > network > start network..
    Allora qualcosa deve essere andato storto perchè nella mia versione di BT sotto la voce internet non trovo wicd e sotto menu>service>network non c'è start network...

    Bha?!?

  5. #5
    Member ReversaL's Avatar
    Join Date
    Jan 2010
    Posts
    166

    Default

    senza usare l'interfaccia grafica puoi semplicemente dare i comandi:
    Code:
    wicd
    wicd-client
    dopo questi dovresti vedere l'icona del network in basso a destra..

    ciao!

  6. #6
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    9

    Default

    Anche da shell non va.
    Il bello è che se avvio con modalità live trovo tutti i comandi.
    Se avvio in persistant mode invece no.
    è come se non venisse caricato il servizio.

    Bha?!?

  7. #7
    Senior Member ghostdog67's Avatar
    Join Date
    Sep 2008
    Posts
    180

    Default

    Ciao, non so quale versione BT4 usi? la Pre-final o' la final?
    Nella pre-final devi entrare da root: nel shell scrivi : sudo -i , poi emmetti la tua password.
    Nella Final non c'e bisogno.
    Apri la shell e scrivi: /etc/init.d/wicd start poi ENTER.
    se non ci sono errors, vai a BT menu, " in angolo sotto lo schermo a sinistra"/
    Apri il menu e vai a " internet"
    Dal menu di internet clicca su: " Wicd network manager"
    Se la tua wireless card viene ricinosciuta, una finestra si apre e vedrai la tua rete e se ci sono altri rete vicini, appariranno anche quelle.
    Ora, sotto alla tua rete, clicca su " Advanced"
    Seleziona il tipo di incripzione che hai sulla tua rete: se WEP, seleziona " Wep Hex" se " WPA, Seleziona quella, emmetti la tua password o' la chiave, fatto quello, clicca su " Connect".
    Se tutto va' bene, una barra si muovera' da destra a sinistra e viceversa, vedrai scritto sotto, " Aquiring Network adress, poi Getting IP address.
    Alla fine quando si connette, vedrai il nome della tua rete, la potenza del segnale e il tuo IP address.

    Spero che questo aiuta.
    GD

  8. #8
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    9

    Default

    Quote Originally Posted by ghostdog67 View Post
    Ciao, non so quale versione BT4 usi? la Pre-final o' la final?
    Nella pre-final devi entrare da root: nel shell scrivi : sudo -i , poi emmetti la tua password.
    Nella Final non c'e bisogno.
    Apri la shell e scrivi: /etc/init.d/wicd start poi ENTER.
    se non ci sono errors, vai a BT menu, " in angolo sotto lo schermo a sinistra"/
    Apri il menu e vai a " internet"
    Dal menu di internet clicca su: " Wicd network manager"
    Se la tua wireless card viene ricinosciuta, una finestra si apre e vedrai la tua rete e se ci sono altri rete vicini, appariranno anche quelle.
    Ora, sotto alla tua rete, clicca su " Advanced"
    Seleziona il tipo di incripzione che hai sulla tua rete: se WEP, seleziona " Wep Hex" se " WPA, Seleziona quella, emmetti la tua password o' la chiave, fatto quello, clicca su " Connect".
    Se tutto va' bene, una barra si muovera' da destra a sinistra e viceversa, vedrai scritto sotto, " Aquiring Network adress, poi Getting IP address.
    Alla fine quando si connette, vedrai il nome della tua rete, la potenza del segnale e il tuo IP address.

    Spero che questo aiuta.
    GD
    Allora BT4 final
    da shell
    /etc/init.d/wicd start

    mi viene restituita la riga senza nulla

    vado in internet e nulla... il wicd non c'è.

    in pratica il demone non parte

  9. #9
    Member ReversaL's Avatar
    Join Date
    Jan 2010
    Posts
    166

    Default

    prova fare una cosa, scrivi i due comandi che ti ho detto sopra:
    Code:
    root@bt:~# wicd
    /var/run/wicd/wicd.pid
    root@bt:~# wicd-client
    Loading...
    Attempting to connect tray to daemon...
    Success.
    Done.
    poi controlla se i processi di wicd sono attivi con
    Code:
    ps -e |grep wicd
    in output ti dovrebbe dare tre processi: wicd, wicd-monitor, wicd-client

    NOTA: una volta aperto il client da console, NON la devi chiudere! sennò termina il processo del client!! quindi dai i primi due comandi e poi in un'altra console controlli se sono attivi.


    se non ti da l'output esatto prova a reinstallare wicd:
    Code:
    root@bt:~# apt-get remove wicd
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      wpasupplicant
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
      setup-gpsd setup-network setup-pcscd wicd
    0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
    After this operation, 2093kB disk space will be freed.
    Do you want to continue [Y/n]? Y
    (Reading database ... 225594 files and directories currently installed.)
    Removing setup-gpsd ...
    Removing setup-network ...
    Removing setup-pcscd ...
    Removing wicd ...
    Stopping Network connection manager: wicd.
    Processing triggers for man-db ...
    root@bt:~# apt-get install setup-gpsd setup-network setup-pcscd wicd
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
      setup-gpsd setup-network setup-pcscd wicd
    0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/257kB of archives.
    After this operation, 2093kB of additional disk space will be used.
    Selecting previously deselected package wicd.
    (Reading database ... 225393 files and directories currently installed.)
    Unpacking wicd (from .../archives/wicd_1.5.8_all.deb) ...
    Selecting previously deselected package setup-gpsd.
    Unpacking setup-gpsd (from .../setup-gpsd_1.0-bt1_i386.deb) ...
    Selecting previously deselected package setup-network.
    Unpacking setup-network (from .../setup-network_1.0-bt1_i386.deb) ...
    Selecting previously deselected package setup-pcscd.
    Unpacking setup-pcscd (from .../setup-pcscd_1.0-bt1_i386.deb) ...
    Processing triggers for man-db ...
    Setting up wicd (1.5.8) ...
    ls: cannot access /opt/wicd/encryption/configurations/: No such file or directory
    Starting Network connection manager: wicd.
    
    Setting up setup-gpsd (1.0-bt1) ...
    Setting up setup-network (1.0-bt1) ...
    Setting up setup-pcscd (1.0-bt1) ...
    riprova tutta la procedura (wicd ; wicd-client ; ps -e |grep wicd)


    se ancora non va, vai nella cartella /etc/init.d e postaci il contenuto di wicd, perchè sembra strano che ti dia come output una linea nulla.

    ciao!

  10. #10
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    9

    Default

    Allora alla fine ho risolto.
    In pratica wicd non era installato.
    Lanciato synaptic e cercato wicd, infatti, mi diceva non installato.
    Poichè comunque non mi lasciava installarlo da synaptic per mancanza di connessione, ho scaricato su un altro pc la versione deb di wicd.

    Lo installata e ora ti scrivo da bt4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •