Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Alfa AWUS036H da 1 Watt

  1. #1
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    9

    Default Alfa AWUS036H da 1 Watt

    salve gente ho acquistato l'antenna in oggetto da 1W ma se provo ad attivare l'highpower col comando iwpriv mi risponde

    root@bt:~# iwpriv wlan1 highpower 1
    wlan1 no private ioctls

    col comando

    iwconfig wlan1 txpower 27

    riesco comunque a portarla a 500mW ma se provo ad andare oltre mi risponde

    Error for wireless request "Set Tx Power" (8B26) :
    SET failed on device wlan1 ; Invalid argument."

    come faccio a farla andare a 1W? il mio OS è backtrack4-final
    grazie a tutti

  2. #2
    Member ReversaL's Avatar
    Join Date
    Jan 2010
    Posts
    166

    Default

    non sono sicuro perchè ancora non ho provato.. ma visto che stavo anche io aspettando l'alfa da 1W mi sono andato a leggere un pò di thread su wifi-italia.

    prova a dare il comando
    Code:
    iwpriv wlan1 rawtx 1
    invece di "iwpriv wlan1 highpower 1"

    da quello che ho capito il comando che usi tu è utilizzato per i driver patchati, quest'altro si usa invece per quelli non patchati.

    questi due comandi servono per convertire i valori che vai ad impostare con txpower in dBm, quindi per l'alfa da 1W dovrebbero arrivare fino a 30dBm.

    poi quando mi arriverà il giocattolino ti saprò dire meglio

    p.s.: ringrazio jano di wifi-ita e ti linko il THREAD

    ciao

  3. #3
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    9

    Default

    pubblico di seguito l'output del tentativo di installazione sulla mia BT4 final dei driver patchati per l'AWUS036H da 1 watt presi dal sito di Aircrack:

    [COLOR="Yellow"]
    patching file beta-8187/ieee80211_crypt.h
    patching file beta-8187/ieee80211.h
    patching file beta-8187/Makefile
    patching file beta-8187/r8180_93cx6.c
    patching file beta-8187/r8180_hw.h
    patching file beta-8187/r8180_rtl8225.c
    patching file beta-8187/r8180_rtl8225.h
    patching file beta-8187/r8180_rtl8225z2.c
    patching file beta-8187/r8180_wx.c
    patching file beta-8187/r8187_core.c
    patching file beta-8187/r8187_core.c~
    patching file beta-8187/r8187.h
    patching file beta-8187/r8187.h~
    patching file beta-8187/.tmp_versions/r8187.mod
    patching file ieee80211/ieee80211_crypt.c
    patching file ieee80211/ieee80211_crypt_ccmp.c
    patching file ieee80211/ieee80211_crypt.h
    patching file ieee80211/ieee80211_crypt_tkip.c
    patching file ieee80211/ieee80211_crypt_wep.c
    patching file ieee80211/ieee80211.h
    patching file ieee80211/ieee80211_module.c
    patching file ieee80211/ieee80211_rx.c
    patching file ieee80211/ieee80211_softmac.c
    patching file ieee80211/ieee80211_softmac_wx.c
    patching file ieee80211/ieee80211_tx.c
    patching file ieee80211/ieee80211_wx.c
    patching file ieee80211/Makefile
    patching file ieee80211/Modules.symvers
    patching file ieee80211/.tmp_versions/ieee80211_crypt_ccmp-rtl.mod
    patching file ieee80211/.tmp_versions/ieee80211_crypt-rtl.mod
    patching file ieee80211/.tmp_versions/ieee80211_crypt_tkip-rtl.mod
    patching file ieee80211/.tmp_versions/ieee80211_crypt_wep-rtl.mod
    patching file ieee80211/.tmp_versions/ieee80211-rtl.mod
    patching file makedrv~
    patching file Makefile
    patching file ReadMe.txt~
    patching file symvers
    patching file wlan0rmv
    rm -f ieee80211/Module.symvers 2>/dev/null
    rm -f ieee80211/Modules.symvers 2>/dev/null
    make -C ieee80211 all
    make[1]: Entering directory `/root/rtl8187_linux_26.1010.0622.2006/ieee80211'
    make -C /lib/modules/2.6.30.9/build M=/root/rtl8187_linux_26.1010.0622.2006/ieee80211 modules
    make[2]: Entering directory `/usr/src/linux-source-2.6.30.9'

    WARNING: Symbol version dump /usr/src/linux-source-2.6.30.9/Module.symvers
    is missing; modules will have no dependencies and modversions.


    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_softmac.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_rx.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_tx.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_wx.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_module.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_softmac_wx.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_ccmp.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_tkip.o
    CC [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_wep.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211-rtl.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt-rtl.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_wep-rtl.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_tkip-rtl.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_ccmp-rtl.o
    Building modules, stage 2.
    MODPOST 5 modules
    CC /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211-rtl.mod.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211-rtl.ko
    CC /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt-rtl.mod.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt-rtl.ko
    CC /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_ccmp-rtl.mod.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_ccmp-rtl.ko
    CC /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_tkip-rtl.mod.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_tkip-rtl.ko
    CC /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_wep-rtl.mod.o
    LD [M] /root/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_wep-rtl.ko
    make[2]: Leaving directory `/usr/src/linux-source-2.6.30.9'
    make[1]: Leaving directory `/root/rtl8187_linux_26.1010.0622.2006/ieee80211'
    chmod +x symvers
    ./symvers
    make -C beta-8187 all
    make[1]: Entering directory `/root/rtl8187_linux_26.1010.0622.2006/beta-8187'
    make -C /lib/modules/2.6.30.9/build M=/root/rtl8187_linux_26.1010.0622.2006/beta-8187 modules
    make[2]: Entering directory `/usr/src/linux-source-2.6.30.9'

    WARNING: Symbol version dump /usr/src/linux-source-2.6.30.9/Module.symvers
    is missing; modules will have no dependencies and modversions.


    CC [M] /root/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187_core.o
    In file included from /root/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187_core.c:65:
    /root/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187.h:47:27: error: asm/semaphore.h: No such file or directory
    make[3]: *** [/root/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187_core.o] Error 1
    make[2]: *** [_module_/root/rtl8187_linux_26.1010.0622.2006/beta-8187] Error 2
    make[2]: Leaving directory `/usr/src/linux-source-2.6.30.9'
    make[1]: *** [modules] Error 2
    make[1]: Leaving directory `/root/rtl8187_linux_26.1010.0622.2006/beta-8187'
    make: *** [all] Error 2
    install -d /lib/modules/2.6.30.9/kernel/drivers/net/wireless/rtl_ieee80211
    install -d /lib/modules/2.6.30.9/kernel/drivers/net/wireless/rtl8187
    install -m 644 ./ieee80211/*.ko /lib/modules/2.6.30.9/kernel/drivers/net/wireless/rtl_ieee80211
    install -m 644 ./beta-8187/*.ko /lib/modules/2.6.30.9/kernel/drivers/net/wireless/rtl8187
    install: cannot stat `./beta-8187/*.ko': No such file or directory
    make: *** [install] Error 1



    come si vede, ci sono degli errori, forse per un'incompatibilità col kernel attuale. sapete aiutarmi?

    grazie

  4. #4
    Member ReversaL's Avatar
    Join Date
    Jan 2010
    Posts
    166

    Default

    ciao, scusa per aver risposto tardi ma la "piccolina" mi è arrivata oggi

    comunque non so se tu hai risolto, ma alla fine cercando sul nuovo forum di backtrack ho trovato la soluzione!

    devi usare il comando
    Code:
    iw reg set BO
    in pratica, su bt4 sono preinstallati altri driver che non implementano l'iwpriv. con questo comando carichi le impostazioni di default di vari paesi che puoi trovare QUI (in questo caso BOLIVIAAA ) dopo dai il comando
    Code:
    iwconfig wlan0 txpower 30
    e tutto va alla perfezione QUESTO è il thread di cui ti parlavo

    p.s.: se qualcuno però mi spiegasse quegli errori di compilazione ne sarei felice..non riesco a capire!

    ciao!

  5. #5
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    9

    Default

    avevo già provato nel modo citato da te ma non sono comunque riuscito. questo è il riusultato dopo aver dato il comando "iw reg set <IT> oppure <US>"

    root@bt:~# iwconfig wlan1 txpower 30
    Error for wireless request "Set Tx Power" (8B26) :
    SET failed on device wlan1 ; Invalid argument.


    ma la tua è da 1w? e usi la bt4-final? nella mia ignoranza ritengo che il problema sia un'incompatibilità col kernel attuale 2.6.30.9..penso che proverò un downgrade del firmware..ma hai usato i driver del sito Aircrack-ng?

  6. #6
    Member ReversaL's Avatar
    Join Date
    Jan 2010
    Posts
    166

    Default

    leggi bene il comando che ho scritto, non devi usare nè IT nè US! prova con BO e vedi che poi funziona a meraviglia

    anche io ho l'alfa da 1W e sto su bt4-final. i driver che stanno sul sito di aircrack-ng li ho provati ad installare ma senza successo.

    ora con questo metodo funziona tutto benissimo, senza fare modifiche ai driver preinstallati

  7. #7
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    9

    Default [RISOLTO] Alfa AWUS036H 1 watt, highpower, txpower

    ok, risolto. avevi ragione


    w la bolivia!

  8. #8
    Junior Member
    Join Date
    Aug 2009
    Posts
    38

    Default

    ciao a tutti
    anch'io ho comprato un alfa 1000mw e con i comandi sopra elencati sono passato (aprendo wavemon) dai 501mw che mi leggeva prima ai 1000mw di adesso.
    Ma poichè ho anche un'alfa 500mw mi chiedo:
    se ora ci metto sotto l'alfa500mw è tutto ok o ci possono essere problemi?
    E' il caso che per usare la 500 risetti di nuovo al paese italia? (anche se penso che in italia il limite sia 20dbm e non 27!!! (uso bt4pf )
    ciao

  9. #9
    Member ReversaL's Avatar
    Join Date
    Jan 2010
    Posts
    166

    Default

    ho sentito che alzando troppo la potenza si potrebbe danneggiare l'alfa, ma non ti so dire se ciò sia vero! non so neanche se quell'impostazione vale per tutte le "WLAN0" oppure se riconosce le schede diverse
    però per evitare problemi, puoi lasciare invariata l'opzione del paese, agendo solo sul comando txpower

    ad esempio.. quando metti l'alfa da 1W stai con "txpower 30" , quando devi passare a quella da 500mW imposti prima "txpower 27".. così stai sicuro

  10. #10
    Junior Member
    Join Date
    Aug 2009
    Posts
    38

    Default

    ciao a tutti
    grazie per il suggerimento utile ed accorto, ma in realtà, almeno nel mio caso, ho notato che devo ridare i comandi ogni volta che reboot, perchè altrimenti mi ritorna alla potenza di default (cioè con alfa 1000 continua ad indicarmi 27 dbm)
    ciao

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •