Results 1 to 3 of 3

Thread: python error

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    4

    Default python error

    hello,
    installing nmap 5.20 but gives error that does not make sense..

    Code:
    oot@bt:/pentest/database/sqlmap# rpm -vhU link-to-nmap-package.rpm
    Retrieving nmap.org/dist/nmap-5.20-1.i386.rpm
    error: Failed dependencies:
            /usr/bin/python is needed by nmap-5.20-1.i386
            python >= 2.4 is needed by nmap-5.20-1.i386
    root@bt:/pentest/database/sqlmap# python -V
    Python 2.5.2

  2. #2
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default

    I can't boot my BT box at the moment as it's in another room, but:

    Code:
    ls -l /usr/bin/python
    Does it exist? If not:
    Code:
    which python
    ln -s /usr/bin/python path.to.location.from.which.command
    Cheat
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by sha-1 View Post
    hello,
    installing nmap 5.20 but gives error that does not make sense..

    Code:
    oot@bt:/pentest/database/sqlmap# rpm -vhU link-to-nmap-package.rpm
    Retrieving nmap.org/dist/nmap-5.20-1.i386.rpm
    error: Failed dependencies:
            /usr/bin/python is needed by nmap-5.20-1.i386
            python >= 2.4 is needed by nmap-5.20-1.i386
    root@bt:/pentest/database/sqlmap# python -V
    Python 2.5.2
    My question is why are you installing a "rpm" into a debian based system? That makes no sense. apt-get install nmap
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •