En el caso de PCs algo lentos como netbooks se hace muy dificil identificar y solucionar este error, puesto que al lanzar "startx", el demonio "artsd" (de la tarjeta de sonido) come todos los recursos del sistema.

Link de referencia:
3w.backtrack-linux.org/forums/backtrack-fixes/23-artsd-eating-up-cpu-vmare-image.html (3w=tres uves dobles)

Soluciones:

- Actualizar a la ultima version de vmware. (no creo que sea necesario, pero noté cierta mejoría con la v.7).
Te saldrá antes la ventana de error del proceso "artsd".

- Cuando arranques BT4-vmware, espera a que te salga una ventana de error advirtiendo del mal funcionamiento del proceso "artsd". (suele tardar en salir dependiendo de lo rapido que se tu PC)
Termina ahí con dicho proceso, quedará solucionado el error para futuros arranques. Creo que es la mejor opción.

- Con el comando "top" identificar el proceso, anotar el PID y matarlo con "kill -9 PID"

- En el menú KDE seleccionar "Preferencias/Audio & Multimedia/Ajustes de sonido" y modificarlo, seleccionando en harware "Advanced Linux Sound Architecture"..

- Comando "update-rc.d-f foobar delete" (foobar=marcador de posición).

- En el menú KDE seleccionar "Sistema/Ajustes/Sonido y multimedia/sistema de sonido" en "enable sound system" desmarcar "Habilitar el sistema de sonido"

- En configuracion de sonido del vmware activar la opción "Specify host sound card" y elige tu tarjeta.

- En caso extremo puedes desactivar la tarjeta de sonido en configuración vmware antes de arrancar.


Es un caso poco frecuente, de los que te puedes comer la cabeza durante mucho tiempo, sobre todo si se trata de un PC lento (netbooks..).

Espero que sea útil.

by donshine.