Results 1 to 3 of 3

Thread: Problem With Unmet Dependencies

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    5

    Default Problem With Unmet Dependencies

    Hey everyone,

    I am somewhat new to this whole thing and I recently installed BT4 to my hard drive. I followed a tutorial to update the kernel and one of the steps was apt-get update. This worked except for I cannot install anything because of the following message which I am not sure how to fix...


    The following packages have unmet dependencies:
    python-scapy: Depends: scapy2 but it is not installed
    scapy: Depends: scapy2 but it is not installed
    E: Unmet dependencies. Try using -f.


    I have tried using apt-get install -f but I get the following error..

    Do you want to continue [Y/n]? y
    (Reading database ... 234794 files and directories currently installed.)
    Unpacking scapy2 (from .../scapy2_2.1-bt1_all.deb) ...
    dpkg: error processing /var/cache/apt/archives/scapy2_2.1-bt1_all.deb (--unpack):
    trying to overwrite `/opt/kde3/share/applications/external/scapy.desktop', which is also in package scapy-menu
    Processing triggers for man-db ...
    Errors were encountered while processing:
    /var/cache/apt/archives/scapy2_2.1-bt1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)



    Any help would be greatly appreciated.


    Thanks,
    Eternal Unknown

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    There is a recent thread on this already. Use the search feature and you will find it.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    5

    Default

    so basically, from what I could gather through reading, this problem is one that is broken on Backtacks end and it is working on being fix. So eventually i will be able to fix it be doing apt-get update & apt-get dist-upgrade?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •