Hola a todos, este es mi primer post en este foro y espero que no el ultimo (soy muy vago).

Llevo usando GNU/Linux desde hace unos años y Backtrack siempre ha estado presente a pesar de que soy usuario de Gentoo.

Acabo de bajarme la bt4final y estoy encantado: ha ido derechita a mi asus eeepc 901. Pero cual es mi sorpresa al encenderlo que no es capaz de levantar la interfaz ra0!

Si hacéis un dmesg | tail después de hacer un ifconfig ra0 up y que os de el error veréis que no encuentra el RT2860STA.dat en la carpeta RT2860STA la cual ni si quiera existe en el path /etc/Wireless

¿Solución?

EDITO:
Me he dado cuenta de que wicd y knetworkmanager no conectan (knetwork ni si quiera ve la interfaz) Así que he conseguido el RT2860STA.dat oficial:

#The word of "Default" must not be removed
Default
CountryRegion=5
CountryRegionABand=7
CountryCode=
ChannelGeography=1
SSID=
NetworkType=Infra
WirelessMode=5
Channel=0
BeaconPeriod=100
TxPower=100
BGProtection=0
TxPreamble=0
RTSThreshold=2347
FragThreshold=2346
TxBurst=1
PktAggregate=0
WmmCapable=1
AckPolicy=0;0;0;0
AuthMode=OPEN
EncrypType=NONE
WPAPSK=
DefaultKeyID=1
Key1Type=0
Key1Str=
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
PSMode=CAM
AutoRoaming=0
RoamThreshold=70
APSDCapable=0
APSDAC=0;0;0;0
HT_RDG=1
HT_EXTCHA=0
HT_OpMode=1
HT_MpduDensity=4
HT_BW=1
HT_AutoBA=1
HT_BADecline=0
HT_AMSDU=0
HT_BAWinSize=64
HT_GI=1
HT_MCS=33
HT_MIMOPSMode=3
HT_DisallowTKIP=1
IEEE80211H=0
TGnWifiTest=0
WirelessEvent=0
CarrierDetect=0
AntDiversity=0
BeaconLostTime=4
En lugar de copiar el RT2870STA.dat copiar ese contenido al RT2860STA.dat

No se si cambia esto en algo, no tengo el portátil a mano ahora mismo.
-----
Muy sencilla: copiar el dat de RT2870STA a el de RT2860STA.

Code:
mkdir -p /etc/Wireless/RT2860STA
cp /etc/Wireless/RT2870STA/RT2870STA.dat /etc/Wireless/RT2860STA/RT2860STA.dat
Y listo. Ya podréis hacer un ifconfig ra0 up y disfrutar.

No se si se trata de un bug. De todas formas aquí esta la solución. Si algún moderador puede reportarlo mejor que mejor