Results 1 to 4 of 4

Thread: Kismet configuration on Asus EeePC 1005HA

Hybrid View

  1. #1
    Junior Member whiterabbit7500's Avatar
    Join Date
    Feb 2010
    Location
    in your server
    Posts
    33

    Default Kismet configuration on Asus EeePC 1005HA

    I've read through 99% of the other "kismet config" help threads, and can't find any help with this. I'm running this on Ubuntu 9.1 on my 1005HA. I know it's not BT, but I figure I can find more help here then anywhere else.

    lshw -C network output
    Code:
    *-network
           description: Wireless interface
           product: AR9285 Wireless Network Adapter (PCI-Express)
           vendor: Atheros Communications Inc.
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: wmaster0
           version: 01
           serial: 00:25:d3:72:d0:2b
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
           configuration: broadcast=yes driver=ath9k ip=10.1.1.3 latency=0 multicast=yes wireless=IEEE 802.11bgn
           resources: irq:17 memory:fbff0000-fbffffff
      *-network
           description: Ethernet interface
           product: Atheros AR8132 / L1c Gigabit Ethernet Adapter
           vendor: Attansic Technology Corp.
           physical id: 0
           bus info: pci@0000:01:00.0
           logical name: eth0
           version: c0
           serial: 90:e6:ba:20:ea:f9
           capacity: 100MB/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.0.1-NAPI firmware=N/A latency=0 link=no multicast=yes port=twisted pair
           resources: irq:28 memory:f7fc0000-f7ffffff ioport:ec00(size=128)
    .config file (The relevant part at least)
    Code:
    # Kismet config file
    # Most of the "static" configs have been moved to here -- the command line
    # config was getting way too crowded and cryptic.  We want functionality,
    # not continually reading --help!
    
    # Version of Kismet config
    version=2007.09.R1
    
    # Name of server (Purely for organizational purposes)
    servername=Kismet
    
    # User to setid to (should be your normal user)
    #suiduser=your_user_here
    
    # Do we try to put networkmanager to sleep?  If you use NM, this is probably
    # what you want to do, so that it will leave the interfaces alone while
    # Kismet is using them.  This requires DBus support!
    networkmanagersleep=true
    
    # Sources are defined as:
    # source=sourcetype,interface,name[,initialchannel]
    # Source types and required drivers are listed in the README under the
    # CAPTURE SOURCES section.
    # The initial channel is optional, if hopping is not enabled it can be used
    # to set the channel the interface listens on.
    # YOU MUST CHANGE THIS TO BE THE SOURCE YOU WANT TO USE
    source=ath9k,wlan0,Wireless
    Output I receive
    Code:
    whiterabbit@WR-netbook:/etc/kismet$ sudo kismet
    Launching kismet_server: //usr/bin/kismet_server
    Suid priv-dropping disabled.  This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    FATAL: Unknown capture source type 'ath9k' in source 'ath9k,wlan0,Wireless'
    Done.
    I checked the driver name, which in my case is ath9k, set the interface to wlan0, and the name to Wireless. Should I be using something different? How can I get this working?

  2. #2
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    What does iwconfig give you?

  3. #3
    Junior Member whiterabbit7500's Avatar
    Join Date
    Feb 2010
    Location
    in your server
    Posts
    33

    Default

    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:""
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
              Tx-Power=20 dBm
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    not seeing anything there that would help though. Should I be looking for something?

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by whiterabbit7500 View Post
    I've read through 99% of the other "kismet config" help threads, and can't find any help with this. I'm running this on Ubuntu 9.1 on my 1005HA. I know it's not BT, but I figure I can find more help here then anywhere else.
    I am sorry but we can not support Ubuntu.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •