I'm playing with this exploit and to use it with versions of Apache other than 1.3.34 it requires you to find new jumpers.
The jumper for 1.3.34, per the exploit, is 0x0834ae77.

The help on finding newer jumps is here and without debugging the app, it looks like bruteforce is the main method?
Some notes on how to find the right address in your specific environment to exploit Apache.

I'm mainly curious if anyone already has a fixed copy of this exploit for newer versions of apache.
Or if anyone can think of an alternate way to find the jumper.



Thanks