Results 1 to 3 of 3

Thread: Get compiz-fusion icon to work a la BT3

  1. #1
    Member
    Join Date
    Feb 2007
    Posts
    229

    Default

    Having looked up compiz in synaptic and apt-cache i see a slew of things, both kde3 and non-kde3. Which packages do i need in order to have the same functionality as prior versions of BT3 (mapped desktops, window effects, emerald, and the fusion icon to control it all). I've tried a few variations and ended up breaking my install - it would try to render everything in compiz, resulting in missing window borders and such (i've a 9600GT in my laptop with drivers installed from repos). Worst part is i couldnt get kwin to render things again and given other f-ups with that install i decided it would be best to just start over (the day before muts posts that bt4final should be here soon ).

    Anyway, could someone give me a couple of pointers on how to properly set this up, and how one can switch renderers between compiz and kwin (for a USB install that moves between machines where one may not have an nvidia card). thanks

    Got it. the 190.53 driver seems to have resolved the rendering issues i was getting, installed compiz, compiz-fusion, and emerald and all seems to work just fine.

    Odd question though, how does one make compiz the default renderer for the HD installed OS (obviously dont want that on the USB version since it doesnt need to be pretty)? I need to either run compiz --replace after startx or doing the same via the fusion icon. Where is the default window manager set in the configuration files?

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Mind the edit button.
    Look around in the bt4 tutorial section there might be a guide on it, but if not there are several at ubuntu forums.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Member
    Join Date
    Feb 2007
    Posts
    229

    Default

    The edit button doesnt show anyone reading the forum that there's any reason for them to look at a thread they've seen before as it doesn't change the number of posts in that thread. One would hope that the database running the forum isnt going to keel over a few extra posts .

    anyway, i did look around and from what i can find its supposed to work by default. Matter of fact, it sometimes does start the X server rendering with compiz by default, though its a bit glitchy and i still need to compiz --replace.

    Anyone else ever run into this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •