Results 1 to 9 of 9

Thread: apt-get upgrade Kismet error

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    23

    Default apt-get upgrade Kismet error

    Hello,

    Newbie here. I've search around for a fix for the following, but can't seem to find anything. Can someone please help? Please forgive if I posted this in the wrong section.


    Code:
    root@modem:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages have been kept back:
      backtrack-discovery backtrack-enumeration backtrack-network
    The following packages will be upgraded:
      kismet
    1 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    Need to get 0B/962kB of archives.
    After this operation, 2388kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    (Reading database ... 250155 files and directories currently installed.)
    Preparing to replace kismet 0.1-bt0 (using .../kismet_2008-05-R1-4_i386.deb) ...
    Unpacking replacement kismet ...
    dpkg: error processing /var/cache/apt/archives/kismet_2008-05-R1-4_i386.deb (--unpack):
     trying to overwrite `/usr/bin/kismet', which is also in package kismet-newcore
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Processing triggers for menu ...
    Errors were encountered while processing:
     /var/cache/apt/archives/kismet_2008-05-R1-4_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@modem:~#

  2. #2
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    18

    Default Th3 S01luti0n

    hi man how are you look go to the Synaptic Package Manager then to the custom filter then to the broken i think you will find it there uninstall it then install again i think that may solve the problem.

  3. #3
    mcurran
    Guest

    Default

    BUMP - suggested fix does not work, and neither does completely removing kismet and kismet-newcore and reinstalling those two packages either...

  4. #4
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default

    Quote Originally Posted by mcurran View Post
    BUMP - suggested fix does not work, and neither does completely removing kismet and kismet-newcore and reinstalling those two packages either...
    How did you remove them. What commands did you type. What thoughts do you have.

    These damned packages can be a real pain in the ass to work.
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

  5. #5
    mcurran
    Guest

    Default

    I reinstalled and this is not an issue with the default kernel. I did a search with Konqueror for all packages name kismet and then deleted manually from the terminal.

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    1

    Default

    Open terminal and paste:
    dpkg --force-all -i /var/cache/apt/archives/kismet_2008-05-R1-4_i386.deb

  7. #7
    Member iceman_3233's Avatar
    Join Date
    Jan 2010
    Location
    Fort Washington
    Posts
    56

    Smile Kismet error

    Have you tried running fast-track. It also updates kismet newcore.
    The enemy is no longer ignorance - It is vigilance

  8. #8
    Junior Member jnt13's Avatar
    Join Date
    Feb 2010
    Location
    Ontario, Canada
    Posts
    39

    Default

    Im getting the same issue. I just have Kismet-newcore installed, and everything works fine from what I can tell. Is kismet the old package, and not needed now?

  9. #9
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    21

    Default

    markosd suggestion works but after that do this

    Code:
    apt-get update
    apt-get upgrade
    apt-get dist-upgrade
    the usual way for deb users

    thanx markosd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •