Results 1 to 6 of 6

Thread: Actualizacion en BT4pre al 21 de diciembre

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Question Actualizacion en BT4pre al 21 de diciembre

    buenas! que tal... cansado de llorar en la otra sección por que no me funciona la placa de video, me vengo a llorar aca por que el apt se queja cuando cuando actualizo....
    esto es lo que me pasas cuando hago apt-get && apt-get dist-upgrade:

    pastebin.com/f4ed07c86

    ya tenia backtrack instalado y cuando lo fui a actualizar hace unos días hizo pelota todo, borro metasploit y milw0rm.... y dio muchos problemas para instalar medusa... y encima al final de todo tampoco quedo funcionando la placa de video... rayos! ya tengo 2 problemas, con la distro asi como esta en el live me funciona de lujo, pero que gracia tiene tenerla des-actualizada...

    bueno... espero que alguien me de una mano... deje la instalación ahí donde quedo en el pastebin...
    Saludos!

    hackmaf
    .
    .
    .

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    Para el erro de samdump2:
    Code:
    apt-get remove samdump2-menu
    apt-get install samdump2

  3. #3
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Default Ok! gracias!

    Quote Originally Posted by Snayler View Post
    Para el erro de samdump2:
    Code:
    apt-get remove samdump2-menu
    apt-get install samdump2
    Ok! gracias! pruebo y después comento como me fue!

  4. #4
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Default

    bueno... despues de tanto molestar por el canal de irc me dieron una mano... y esta es la solucion:

    Primero...

    Guardar el archivo xorg.conf si usas nvidia

    #cp /etc/X11/xorg.conf ~/

    Segundo

    descargar el paquete de la ultima version del kernel que hay para BT y luego instalarla

    #apt-get update
    #apt-get install -d linux-image
    #cd /var/cache/apt/archives/
    #dpkg -i –force-all linux-image-2.6.30.5_2.6.30.9-10.00.Custom_i386.deb

    reiniciar y preocurar arrancar con el kernel nuevo

    #apt-get dist-upgrade
    #apt-get install madwifi-drivers
    #apt-get install r8187-drivers

    Tercero
    si postgres da errores como:

    Setting up postgresql-8.3 (8.3.8-0ubuntu8.10) …
    Starting PostgreSQL 8.3 database server: main* The PostgreSQL server failed to start. Please check the log output:
    2009-09-29 12:21:43 BST FATAL: could not load server certificate file “server.crt”: No such file or directory
    failed!
    invoke-rc.d: initscript postgresql-8.3, action “start” failed.
    dpkg: error processing postgresql-8.3 (–configure):
    subprocess post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of postgresql:
    postgresql depends on postgresql-8.3; however:
    Package postgresql-8.3 is not configured yet.
    dpkg: error processing postgresql (–configure):
    dependency problems – leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
    Errors were encountered while processing:
    postgresql-8.3
    postgresql
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    se soluciona creando los archivos de certificacion

    #cd /etc/ssl/certs
    #make-ssl-cert generate-default-snakeoil –force-overwrite

    y ultimo
    #fix-splash

    gracias por la ayuda Error500

    .
    .
    .
    hackmaf

  5. #5
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    1

    Default Reinstalación metasploit y milw0rm etc..

    Que tal hackmaf, tu solucíon me ha servido para arreglar algo similar que tuve al actualizar, pero como hiciste al fin para reinstalar todos los paquetes que se desinstalaron xhydra,metasploit,milw0rm y los otros?

  6. #6
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Question

    La verdad que ni me acuerdo como hice... es un problema no haber documentado todo... pero creo que fue insistir con aptitude y sos posibles soluciones... proba con eso...
    #aptitude install xhydra metasploit milw0rm
    o algo asi... milw0rm ya no lo necesitas, mejor

    svn co svn://devel.offensive-security.com/exploitdb

    y metasploit creo que se volvio a instalar solo... sino baja el paquete e instalalo a manopla con
    #dpkg -i

    Saludos!

    .
    .
    .
    hackmaf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •