So lots of people are getting this error. The way this happens is when you update metasploit via svn from the folder. We try to keep the package in apt-get updated weekly but some people insist on using the svn up command so I decided to post the fix. I initially wrote a article for my friends site so I will just paste the link so i don't have to write it again.

SVN: This client is too old to work with working copy