Results 1 to 6 of 6

Thread: MAC Spoofing error

  1. #1
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    4

    Default MAC Spoofing error

    Hi guys,

    I try to change my MAC using:
    "ifconfig eth1 hw ether 00:11:22:33:44:55"

    and I get:
    "SIOCSIFHWADDR: Too many open files in system"

    when i do a "ifconfig eth1" afterwards it do shows the new MAC (00:11...) instead of my old, but I can't connect to my Wireless AP with Wicd Manager. It says: "Validating authentication..." in the status bar for about 40 secs and then it stops trying to connect.

    Any ideas?

    PS
    I do "ifconfig eth1 down" before and "up" afterwards
    eth1 obviously is my wireless nic
    I have tried /etc/init.d/netwoking stop/start
    I searched google for about an hour and a half(obviously without success
    I'm not a newbie but I'm not much experienced...

  2. #2
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    19

    Default

    Did you try the following:

    ifconfig eth1 down
    macchanger --mac 00:11:22:33:44:55
    ifconfig eth1 up

    This should work for you. Let me know if it doesn't.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    2

    Default

    Quote Originally Posted by plamen View Post
    Hi guys,

    I try to change my MAC using:
    "ifconfig eth1 hw ether 00:11:22:33:44:55"
    Disclaimer: I'm probably not much wiser than you...

    I vaguely remember once reading something somewhere...about how some routers might not let you connect if they don't recognize your MAC vendor code (the first three bytes, 00:11:22 in your case). Try spoofing something more common instead, like Intel's MAC vendor code (00:13:02:33:44:55)

  4. #4
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    4

    Default

    @Zer0|Day
    I get:
    ERROR: Can't change MAC: interface up or not permission: Too many open files in system
    When i do "ifconfig eth1" it gives me the new mac, but again I can't connect to my wireless network.

    @dcx22
    I've tried changing only the last digit of the MAC, but the result is the same.

  5. #5
    Junior Member
    Join Date
    Oct 2008
    Posts
    86

    Default

    did you tried with a random mac address?

    macchanger -r eth1

    any mac filtering enable on the AP?

  6. #6
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    4

    Default

    I've tried with random as well - no results.
    Always I get an error connected with "too many open files".
    I guess something which requires to know my MAC is running all the time. I've tried to put a script in /etc/rcS.d/ to change my mac at boottime, but it doesn't change it for reasons unknown.
    My AP doesn't have MAC restrictions. It has WPA-PSK enabled, and when I try to connect to it after changing the MAC it says "validating authentication" and goes no further. I've tried to remove the WPA security, making the net open, and that it says "obtaining IP", but it won't connect either.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •