Results 1 to 3 of 3

Thread: fast-track can't update msf3?

  1. #1
    Member
    Join Date
    Feb 2007
    Posts
    229

    Default fast-track can't update msf3?

    Working on a new install of BT4pf, i did a full dist-upgrade, .9 kernel, etc.

    As i'm ironing out the bugs and getting this thing ready for compression to a live USB drive, i tried to update fast-track. No dice on msf3 though, it gave me the following:


    "Updating Metasploit....
    svn: This client is too old to work with working copy '/pentest/exploits/framework3'. You need
    to get a newer Subversion client, or to downgrade this working copy."

    Has anyone seen this? doesnt seem to make sense as i just updated everything on the system.

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    2

    Default This might help...

    I found the answer (and finally got it to work...) here:

    xxx.question-defense.com/2009/12/03/svn-this-client-is-too-old-to-work-with-working-copy

    After running the script, I then ran "svn up" while in the framework3 directory.

    If you take a peek at the error message, there's also a link to a page which references the same script.

    Hope that helps.

  3. #3
    Member
    Join Date
    Feb 2007
    Posts
    229

    Default

    Ah, it works. I need to read up a bit on how SVN works i think, my ignorance regarding version control software is starting to impede the stuff im doing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •