Results 1 to 3 of 3

Thread: DHCP problem?

  1. #1
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    1

    Default DHCP problem?

    I have installed Backtrack4 Pre final to my hard drive and are having problems connecting to the internet.

    I am using Wicd to connect to my router. Connecting to the router itself is no problem, however i am unable to reach the internet through it.

    Ive approached this in 2 ways: First i tried connecting to my router by using the static ip addresses (IP, Gateway,Subnet, DNS and so on) that i would normally use to access the internet, once i have entered information in the required feilds, i click connect. It connects to my router almost instantly, however i cant access the internet as i always get "page cannot be displayed"

    The 2nd approach was to connect without using the static IP addresses.(My router has DHCP enabled) However if i try to connect with this method i cannot even connect to my router as it hangs on "obtaining IP address", if i leave it, it eventually says failed to connect.

    using the 1st method, once i had connected to my router i used the ping command to ping google, and my routers IP. In both circumstances it came back with host unreachable.

    I have searched the forums and google but cannot find an answer/explanation to my problem.

    I have used the following code to enable networking and Wicd

    update-rc.d wicd defaults
    /etc/init.d/wicd start
    /etc/init.d/networking start

    I am using a Netgear WG111v2 USB adaptor.
    Im sure there is a simple explanation to this, either that or im missing out something obvious.

    Any help would be greatly appreciated.

  2. #2
    Senior Member Thorn's Avatar
    Join Date
    Jan 2010
    Location
    The Green Dome
    Posts
    1,509

    Default

    Start with the basics. There's no mention of the default route and gateway. Did you set them?
    Thorn
    Stop the TSA now! Boycott the airlines.

  3. #3
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    Sorry I know I post this all the time but really it's the stuff they need to know:

    Linux Internet Connection - Virjacode
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •