Results 1 to 4 of 4

Thread: metasploit and oci8

  1. #1
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    1

    Default metasploit and oci8

    Using msfconsole in updated backtrack 4 pre-final.

    msf > db_autopwn -t -p
    [-] Error while running command db_autopwn: The oci8 module is not available!

    Call stack:
    /opt/metasploit3/msf3/lib/msf/core/exploit/oracle.rb:36:in `rescue in initialize'
    /opt/metasploit3/msf3/lib/msf/core/exploit/oracle.rb:32:in `initialize'
    (eval):35:in `initialize'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:351:in `new'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:351:in `block (2 levels) in cmd_db_autopwn'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:230:in `call'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:230:in `block in each_module_list'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:203:in `each'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:203:in `each_module_list'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:120:in `each_module'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:350:in `block in cmd_db_autopwn'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:348:in `each'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:348:in `cmd_db_autopwn'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:235:in `run_command'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:197:in `block in run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:192:in `each'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:192:in `run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/shell.rb:144:in `run'
    /opt/metasploit3/msf3/msfconsole:92:in `<main>'
    I can't for the life of me figure out what oci8 it's looking for. I've got ruby-oci8 installed, and a complete oracleclient. I appologize if this is something easy, I'm just getting started with metasploit.

  2. #2
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    1

    Default Same here.

    I got a very similar error message however it must be a problem with Metasploit and not Backtrack as I stumbled upon this error in Windows on 2 different machines after running the update command.

  3. #3
    Member cr1spyj0nes's Avatar
    Join Date
    Sep 2008
    Posts
    164

    Default

    im getting the same problem, but im using ubuntu tho.
    I would rather be hated for what i am,
    Then loved for what i am not.

  4. #4
    Member imported_vvpalin's Avatar
    Join Date
    Apr 2009
    Posts
    442

    Default

    This is not the best place to post bugs about msf .. you should be reporting these to hdm via the website as he will be ontop of a fix faster than i cant type pronz.com

    Anyways quick fix for this if it hasn't been patched yet.

    cp /pentest/exploits/framework3/lib/msf/core/exploit/oracle.rb /pentest/exploits/framework3/lib/msf/core/exploit/oracle.rb.bak
    sed -i '/raise RuntimeError/# raise RuntimeError/' /pentest/exploits/framework3/lib/msf/core/exploit/oracle.rb
    Using backtrack for the first time is like being 10 years old again with the keys to a Ferrari.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •