Results 1 to 10 of 14

Thread: rtl8187 channel 12 13 not working anymore on airodump

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    3

    Default rtl8187 channel 12 13 not working anymore on airodump

    HI im kinda new...
    so i have been doing some wep cracking. and it was ok. first on BT3 then BT4 and it was great.

    However some weeks ago my airodump-ng stopped working on ch 12 ... when i fix it with "-c 12" it just says that the channel is fixed on some other. And this concerns only channel 12...

    any help?
    it happened suddenly...

  2. #2
    Member iceman_3233's Avatar
    Join Date
    Jan 2010
    Location
    Fort Washington
    Posts
    56

    Default

    What version of aircrack-ng are you running? Have you updated your drivers.

    Check this out
    r8187 [Aircrack-ng]
    The enemy is no longer ignorance - It is vigilance

  3. #3
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default

    Please edit your previous post instead of making two in a row iceman_3233.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  4. #4
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    11

    Default

    it just says that the channel is fixed on some other

    how do you mean ? on another channell ?and this only happens on c 12 ?
    Are you runing sth else in the background ?

    Please enlighten me ...

    p.s before you post anything else try updating or reinstaling aircrack suit to the latest version (if it worked before it will work again)
    [FONT="Arial Black"][SIZE="4"]If you wait to do everything until you are sure it`s right, you`ll probably never do much of anything.[/SIZE][/FONT]

  5. #5
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    3

    Default

    soo... the case is:
    i have the newest ver. of aircrack.
    i've found some info on aircrack web page not precisely on the subject but still something saying that european card drivers will no longer support ch 12 and 13.

    I tried to downgrade BT4 to make it work - nothing helped. i even reinstalled it on my USB stick but still its the same...

    no other process is going in the backgroound. It is just that my cdriver channel span is 1-11. it hops on 1-11, it captures beacons form 12 because of interferences but i cannot make my interface listen on 12. it just says that it is on some other that i have used before (fe: i used airodump-ng mon0 and stopped sniffing on ch 4, i make airodump-ng -c 12 -w xxx --bssid xx xx xx xx xx xx and it just says that it is sniffing CH 12 but the interface has a fixed channel: 4)...

    Can anyone please advise me something because i really need this and i have not a clue what to do...

  6. #6
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default

    No double posting/bumping please. If someone can help you they will do so. If you havent got any responses yet perhaps you havent provided enough relevant detail.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  7. #7
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    Code:
    iw reg set FR
    Use this command and try airodump again...

  8. #8
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    3

    Default

    Quote Originally Posted by Snayler View Post
    Code:
    iw reg set FR
    Use this command and try airodump again...
    Man, you rule... i dont know what the command is for but it did the trick!
    Great thanks!!

  9. #9
    Just burned his ISO d3faz0r's Avatar
    Join Date
    Jul 2009
    Posts
    4

    Lightbulb Solution

    Edit the "options" file located in:

    /etc/modprobe.d/
    (Use nano or any similar command line text editor. Need to be root or use the "sudo" before the command...)

    sudo nano options

    and add these lines in the end...:

    (Note that you may need to change the name of the module in the
    example for your card's module, the one below is for broadcom)

    options cfg80211 ieee80211_regdom="JP"
    options B43 ieee80211_regdom="JP"


    after that:
    (change the "wlan0" for the name that iwconfig shows you)

    sudo ifconfig wlan0 down
    sudo modprobe -r b43
    sudo modprobe -r cfg80211
    sudo modprobe cfg80211
    sudo modprobe b43
    sudo ifconfig wlan0 up


    That's gonna unlock the 14 channels.

    EDIT: Works fine on BT4 Beta / Pre-Final / Final.

    Enjoy.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •