Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: [Video] Messing with Metasploit

  1. #11
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    2

    Default Re: [Video] Messing with Metasploit

    yas same prob and yes its installed

    can you help me ?

  2. #12
    Moderator g0tmi1k's Avatar
    Join Date
    Feb 2010
    Posts
    1,771

    Default Re: [Video] Messing with Metasploit

    Quote Originally Posted by pheaneasphreak View Post
    Hi everyone. Yesterday i was trying to re-enact this scenario but when it comes to msfconsole i got the following error.

    msf > db_create pheaneasphreak

    Warning: The db_create command is deprecated, use db_connect instead.
    The database and schema will be created automatically by db_connect. If db_connect fails
    to create the database, create it manually with your DBMS' s administration tools.

    createdb: could not connect to database postgres: could not connect to server: No such file or directory
    Is the server running locally and accepting connections to Unix domain socket
    "/var/run/postgresql/ .s.PGSQL.5432" ?
    Error while running command db_create: Failed to connect to database: could not connect to server:
    connection refused.
    Is the server running on host "127.0.01" and accepting TCP/IP connections on port 5432?


    What does that mean and how can i fix that? I am new to this Backtrack thing.Thanks in advance


    pheaneasphreak
    Quote Originally Posted by kataibrengsek View Post
    dear sir,

    when i was typing db_create k4t41, it was appear a command like this : http://i34.tinypic.com/5yaj9z.png
    could someone tell me what was the meaning?

    tks
    Are you using backtrack? Which version?
    I believe thats the error when you don't have the correct driver for the database installed.
    What is the output when you try:
    Code:
    db_driver
    You can either change the driver to one you have install, or install it!
    Code:
    Postgres is the recommended database:
    $ sudo apt-get install postgresql-8.4
    $ sudo apt-get install rubygems libpq-dev
    $ sudo gem install pg
    
    Or for MySQL:
    $ sudo apt-get install mysql-server
    $ sudo apt-get install rubygems libmysqlclient-dev
    $ sudo gem install mysql
    
    Sqlite will work for basic tasks, but is no longer supported!
    $ sudo apt-get install sqlite3
    $ sudo apt-get install rubygems libsqlite3-dev
    $ sudo gem install sqlite3-ruby
    Source: Metasploit Framework - Install Ubuntu - Metasploit Redmine Interface



    Quote Originally Posted by sh0bhit View Post
    thanks for the video
    Thanks for the thanks!



    Quote Originally Posted by viewtifuljoe View Post
    yas same prob and yes its installed

    can you help me ?
    What problem is that? The driver issue?
    What is "its"? What installed?
    Have you...g0tmi1k?

  3. #13
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    5

    Exclamation Re: [Video] Messing with Metasploit

    im using bactrack 4 r1
    this my output on db_driver

    msf > db_driver[*] Active Driver: postgresql[*] Available: postgresql, mysql, sqlite3

    im trying to install the postgresql-8.4
    but the error appeare like this
    #sudo apt-get install postgresql-8.4
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package postgresql-8.4

    how ever im trying to configure my self be stripping the "-"
    and make it #sudo apt-get install postgresql 8.4
    the system told that i've already have the newest postgresql version
    hope u can help to sort out this problem

  4. #14
    Moderator g0tmi1k's Avatar
    Join Date
    Feb 2010
    Posts
    1,771

    Default Re: [Video] Messing with Metasploit

    Quote Originally Posted by m1santrophy View Post
    im using bactrack 4 r1
    this my output on db_driver

    msf > db_driver[*] Active Driver: postgresql[*] Available: postgresql, mysql, sqlite3

    im trying to install the postgresql-8.4
    but the error appeare like this
    #sudo apt-get install postgresql-8.4
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package postgresql-8.4

    how ever im trying to configure my self be stripping the "-"
    and make it #sudo apt-get install postgresql 8.4
    the system told that i've already have the newest postgresql version
    hope u can help to sort out this problem
    Well... Im not sure what your problem is as "postgresql" is installed! You're also using it!
    Code:
    msf > db_driver
    [*] Active Driver: postgresql[*] Available: postgresql, mysql, sqlite3
    Plus when you try to install it again - it says that its installed!
    Have you...g0tmi1k?

  5. #15
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    5

    Default Re: [Video] Messing with Metasploit

    but...
    the problems is i cant create the db..
    seem it appear an error when i'm trying to create it...

  6. #16
    Moderator g0tmi1k's Avatar
    Join Date
    Feb 2010
    Posts
    1,771

    Default Re: [Video] Messing with Metasploit

    Quote Originally Posted by m1santrophy View Post
    but...
    the problems is i cant create the db..
    seem it appear an error when i'm trying to create it...
    What commands are you using?
    Have you...g0tmi1k?

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 2
    Last Post: 08-23-2010, 10:53 AM
  2. [Video] De-ICE.net v1.1 (1.100) {Level 1 - Disk 2}
    By g0tmi1k in forum BackTrack Videos
    Replies: 7
    Last Post: 08-20-2010, 10:00 AM
  3. Replies: 0
    Last Post: 03-16-2010, 01:00 PM
  4. Metasploit auxilary file_autopwn module - Video Tutorial
    By brtw2003 in forum BackTrack Videos
    Replies: 5
    Last Post: 03-13-2010, 11:20 AM
  5. [Video] De-ICE.net v2.0 (1.100) {Level 2 - Disk 1}
    By g0tmi1k in forum BackTrack Videos
    Replies: 0
    Last Post: 02-25-2010, 11:08 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •