Results 1 to 4 of 4

Thread: pci ehternet and 2wire pci wireless adapter not working HELP

  1. #1
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    3

    Default pci ehternet and 2wire pci wireless adapter not working HELP

    I have succesfully installed bt4 onto jumpdrive 8gb, and onto my hardisk, however i have not been able to get my internet to work wirelessly or wired i have a broadcom etherling 10/100 pci card, and i also have a 2wire 802.11g pci wireless adapter with a prismGT chipset and a p54pci driver, however i cannot manage to get either one to be recognized in the hardware manager or find anything on how to get them to work or find the proper drivers or firmware that is required for them to work. They both work beautifully with ubunutu 9.04 without having to do anything special, and they also both work with fedora, however i have not been able to get the wireless card to work with kde, despite all the time i have spent on google, and forums looking for answers and fixes, in ubuntu i did manage to patch the driver for injection that was no big deal, but i have not even been able to get my wired card to work in bt4, i have been attempting for 3 days now, and without an internet connection working i have not been able to try a few of the possibe fixes that i may have found because i cannot succesfully use a apt-get update command because i am not connected, any help would be greatly apreciated.

    Thanks
    Jwaynehinkle

  2. #2
    Junior Member
    Join Date
    Oct 2009
    Posts
    26

    Default

    ifconfig -a --> do you see any interfaces other than the loopback?

  3. #3
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    3

    Default

    There shows a mon0, wlan0, with the loop back of 127.0.0.1 of course, and then it says that there is no access point associated determined or something like that i am typing this from memory for i am not at home in front of my bt4 machine, i also can remember that it does not show my wireless pci card in the hardware, or my ethernet card. worst case i can always go purchase new cards i prefer not to though becuase i have had good luck with these in other linux distros running the same kernal, the pnly problem i have had before was getting packet injection to work but google turned out an easy fix for that, i will post exactly what that command puts out as soon as i get home and i am in front of the machine it should be about 15-16 hours from now, any additional help between now and then from people who have had this same problem, or from people that know how to work around it would be great.

    Thanks for all the help so far.

    I have managed to get my 10/100 ether-net card working finally, i am still unable to get my 2wire pci wireless card to work i have the correct driver installed however when i boot i notice that it says that it cannot find the firmware, also i was wondering if there are any driver updates that allow for packet injection for my particular card i have a prismGT chip-set i know it is supported i also have the p54pci driver not sure if this is supported here is the output for ifconfig -a after i have got my ether-net working please anymore help would be greatly appreciated, thank you so much.

    oot@ace:~# ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:40:2b:30:76:f8
    inet addr:98.156.110.74 Bcast:255.255.255.255 Mask:255.255.224.0
    UP BROADCAST RUNNING MULTICAST MTU:576 Metric:1
    RX packets:13087 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3432 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2979545 (2.9 MB) TX bytes:359594 (359.5 KB)
    Interrupt:18 Base address:0x1800

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:16 errors:0 dropped:0 overruns:0 frame:0
    TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:800 (800.0 B) TX bytes:800 (800.0 B)

    mon0 Link encap:UNSPEC HWaddr 00-60-B3-62-25-B3-30-30-00-00-00-00-00-00-00
    -00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:513 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:57969 (57.9 KB) TX bytes:0 (0.0 B)

    mon1 Link encap:UNSPEC HWaddr 00-60-B3-62-25-B3-00-00-00-00-00-00-00-00-00
    -00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:513 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:57969 (57.9 KB) TX bytes:0 (0.0 B)

    wlan0 Link encap:UNSPEC HWaddr 00-60-B3-62-25-B3-00-00-00-00-00-00-00-00-00 -00
    UP BROADCAST NOTRAILERS PROMISC ALLMULTI MTU:1500 Metric:1
    RX packets:513 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:57969 (57.9 KB) TX bytes:0 (0.0 B)

    wmaster0 Link encap:UNSPEC HWaddr 00-60-B3-62-25-B3-00-00-00-00-00-00-00-00-00 -00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Edit your posts using the Edit button located at the bottom right hand side of said post.
    Re-read the rules that you agreed to when you signed up.
    This is your one and only warning.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •