Results 1 to 5 of 5

Thread: iwl3945 treiber patchen ? injection schlägt fehl

  1. #1
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    4

    Default iwl3945 treiber patchen ? injection schlägt fehl

    hey.
    ich hab in meinem dell eine intel wireless/pro 3945abg karte. ich habe versucht mein wep zu cracken. sowohl ohne clients mit chopchop oder fragmentation attack, als auch mit clients mit normalen arp request. chopchop bekommt nach einer weile (manchmal dauert es ewig ... :X - gibt es da richtlinien wie lange ein AP braucht um ein brauchbares data packet zu senden?) zwar wenn ich glück habe ein data packet, aber kann damit nicht weiterarbeiten. es kommt denn die fehlermeldung

    Code:
    The chopchop attack appears to have failed. Possible reasons:
    
    * You're trying to inject with an unsupported chipset (Centrino?).
    * The driver source wasn't properly patched for injection support.
    * You are too far from the AP. Get closer or reduce the send rate.
    * Target is 802.11g only but you are using a Prism2 or RTL8180.
    * The wireless interface isn't setup on the correct channel.
    * The AP isn't vulnerable when operating in non-authenticated mode.
    Run aireplay-ng in authenticated mode instead (-h option).
    bei der fragmentation attack:

    Code:
    Saving chosen packet in replay_src-129-01.cap
    10:39:23 Data packet found!
    10:39:23 Sending fragmented packet
    10:39:23 Not enough acks, repeating...
    10:39:23 Sending fragmented packet
    10:39:25 No answer, repeating...
    10:39:25 Trying a LLC NULL packet
    10:39:25 Sending fragmented packet
    10:39:26 No answer, repeating...
    10:39:26 Sending fragmented packet
    10:39:28 No answer, repeating...
    10:39:28 Trying a LLC NULL packet
    10:39:28 Sending fragmented packet
    10:39:29 No answer, repeating...
    10:39:29 Sending fragmented packet
    bei -3 bekommt er erst einmal keine arp's und sendet somit auch nichts. dann deauthe ich einen anderen client, was auch funktioniert, und er bekommt ein paar arps und sendet wie verrückt. #data steigt damit allerdings nicht. (teils steigt sie einfach so beim lauschen mit airodump-ng

    zu weit weg bin ich wohl nicht, da der ap direkt im raum nebenan steht.
    fakeauthentication funktioniert übrigens wunderbar.

    wenn ihr noch irgendwelche infos braucht, fragt nach.

    ps: ich werde das hier auch noch im englischen forum posten, da ich nicht weiß wie aktiv das deutsche ist. den link poste ich dann gleich noch hier rein

    lg,
    compul

    ####edit####

    ich habe bt4 pre final vom usbstick mit kernel 2.6.29.4 laufen

  2. #2
    Moderator
    Join Date
    Jan 2010
    Posts
    167

    Default

    ich habe bt4 pre final vom usbstick mit kernel 2.6.29.4 laufen
    Hast du schonmal die BT3 getestet? Ich hatte mit der 4er teilweise ähnliche Probleme.

    lg
    m-1-k-3

  3. #3
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    4

    Default

    ne.
    ich gehe gerade mal die schritte dieses
    h x x p://forums.remote-exploit.org/backtrack-4-working-hardware/27565-bt4-pre-final-driver-iwl3945-injection-solved.html#post156563

    tutorials durch, und schaue dann wie es ausschaut. ansonsten teste ich mal die bt3 final...

    ich glaube ich habe die geschichte aber prinzipiell noch nicht ganz verstanden...
    muss man um injection ans laufen zu bekommen grundsätzlich irgendwelche treiber patchen, oder wie läuft die ganze geschichte ab? ich bin sehr neu, deswegen tappe ich noch im nebel umher... :P

    lg

    ok, also ich diese seite befolgt.

    nach wie vor:

    Code:
    aireplay-ng -9 -a <AP-BSSID> mon0
    
    Waiting for beacon frame (BSSID: <AP-BSSID>) on channel X
    Trying broadcast probe requests...
    Injection is working!
    Found 1 AP
    
    Trying direct probe requests
    <AP-BSSID> - channel: X - 'AP-ESSID'
    Ping (min/avg/max): xxms/xxms/xxms Power: -53.30
    30/30: 100%
    wenn ich nachdem ein paar arps gefangen wurden den anderen client disconnecte werden auch konstant 0#/s gesammelt.

    direkt ein injection problem kann es aber doch nicht sein eig. siehe aireplay-ng -9, oder?

    woran kann das liegen?

    lg...

  4. #4
    Moderator
    Join Date
    Jan 2010
    Posts
    167

    Default

    woran kann das liegen?

    lg...
    Hast du evtl. mehrere Laptops und Access Points zur Verfügung? ich hatte hier einen Laptop mit PCMCIA Karte der keine vernünftige Paketrate brachte. Die selbe Karte in einem anderen Laptop brachte Rekordwerte. Häufig spielt auch der Access Point und der Abstand zu diesem eine entscheidende Rolle. Wichtig für erste Tests ist dass das Signal nicht durch irgendwelche Wände oder sonstige Hindernisse abgeschwächt wird.

    hf
    m-1-k-3

  5. #5
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    4

    Default

    ich habe nur einen AP. zwar mehrere notebooks, aber die karte ist ja intern.

    ich habe mal zweimal
    airmon-ng start wlan0

    gemacht und anschließend
    aireplay-ng -9 mon0 -i mon1

    heraus kam, dass die letzten beiden tests, d.h. -2/-3/-4/-6 und -5/-7 fehlschlugen. in der aircrack-ng doku zum iwl3945 driver steht, dass man compat-wireless installieren muss, damit injection funktioniert. das hab ich gemacht (compat-wireless-2.6.32.5 oder so, mein kernel ist 2.6.30.. ist das mist? ;P) auf jeden fall war danach das device wlan0 nicht mehr da. als lösung ist schon in oben genanntem fred ein link angegeben. wireless-testing installieren. kann ich atm aber alles nicht ausprobieren, da mein akku verreckt ist und ich jetzt wohl spät nachts mist gebaut hab :P ich kann meine mit luks encrypteten partitionen zwar von ner liveCD noch mounten, aber (noch?) nicht (wieder) booten. falls du dazu was weißt / interesse hast / was sagen willst (oder wer anders)

    linuxquestions.org/questions/debian-26/boot-stops-after-fsck-in-maintainance-mode-764167

    ist auf englisch...

    lg... ne besondre idee? ansonsten melde ich mich wieder wenn mein system wieder läuft

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •