Hi,

I'm testing the new bt4 pre release and I'm unable to use medusa or hydra over SSH.

medusa seems to stop working after the 3rd try. Googling around seems that there is a patch for the ssl module that works.

hydra instead seems is compiled without the ssl module support.

below the output of the two commands:

root@bt:/rofs/pentest/passwords/wordlists# medusa -h testsvr.local -u root -P darkc0de.lst -M ssh
Medusa v1.4 [www] (C) JoMo-Kun / Foofus Networks <jmk@foofus.net>

ACCOUNT CHECK: [ssh] Host: 192.168.0.1 (1/1) User: root (1/1) Password: [1B] (1/1707655)
ACCOUNT CHECK: [ssh] Host: 192.168.0.1 (1/1) User: root (1/1) Password: [1B][1B] (2/1707655)
ACCOUNT CHECK: [ssh] Host: 192.168.0.1 (1/1) User: root (1/1) Password: [1B][1B][1B] (3/1707655)
ACCOUNT CHECK: [ssh] Host: 192.168.0.1 (1/1) User: root (1/1) Password: [1B][1B][1B][1B] (4/1707655)
ERROR: Failed to retrieve supported authentication modes. Aborting...
ERROR: No supported authentication methods located.
ACCOUNT CHECK: [ssh] Host: 192.168.0.1 (1/1) User: root (1/1) Password: [1B][1B][1B][1B][1B] (5/1707655)
----------------------------------------

root@bt:/rofs/pentest/passwords/wordlists# hydra -l root -P darkc0de.lst -S -e ns testsvr.local ssh2
Error: Compiled without LIBSSH support, module not available!
----------------------------------------

Could I miss something?

thank you