Results 1 to 10 of 10

Thread: artsd eating up cpu in vmare image

  1. #1
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default artsd eating up cpu in vmare image

    If the arts daemon starts eating up your cpu resources in the vmware image from the official download then you will need to kill the
    process.
    Use top at the command line to verify that it is running and note the PID. Then use # kill -9 PID to terminate the process.

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    6

    Default Re: artsd eating up cpu in vmare image

    By chance did you happen to try and change any settings in the alsa config or Sound I/O tab to see if artsd stopped eating resources?

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010
    Location
    Hungary
    Posts
    1

    Default Re: artsd eating up cpu in vmare image

    Quote Originally Posted by Archangel.Amael View Post
    If the arts daemon starts eating up your cpu resources in the vmware image from the official download then you will need to kill the
    process.
    Use top at the command line to verify that it is running and note the PID. Then use # kill -9 PID to terminate the process.
    Killing <any_application_name> could be really hard, if cpu usage is at the maximum, so a single line command should be better, like kill -9 `pidof artsd`. Then all instances of artsd will be killed out.

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: artsd eating up cpu in vmare image

    I threw the above post up yesterday because muts asked me to. I did do it in a bit of haste. Using "one line commands" are generally the better approach especially when dealing with the aforementioned type of situation.

    Also note that removing the arts daemon from startup will also remove this "problem" from future recurrences.

  5. #5
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    6

    Default Re: artsd eating up cpu in vmare image

    Through KDE Menu Settings/Sound & Multimedia/Sound Settings--> Under the General Tab I deselected Run with highest... and under the Hardware tab I have selected Advanced Linux Sound Architecture.

    This more of a band-aid since artsd still utilizes high cpu, but will still allow one to work with an adequate application response time.

    Another option is to select OSS and artsd drops next to nil , but very poor or no sound.

  6. #6
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default Re: artsd eating up cpu in vmare image

    I had this issue as well and I just removed it completely from start up.

    update-rc.d -f foobar remove

  7. #7
    Member
    Join Date
    Jan 2010
    Posts
    102

    Default Re: artsd eating up cpu in vmare image

    Quote Originally Posted by pureh@te View Post
    I had this issue as well and I just removed it completely from start up.

    update-rc.d -f foobar remove
    I tied this & restarted backtrack and im still getting the artsd pid showing up.

  8. #8
    trellis
    Guest

    Default Re: artsd eating up cpu in vmare image

    Quote Originally Posted by MassAppeal View Post
    I tied this & restarted backtrack and im still getting the artsd pid showing up.
    'foobar' is just a placeholder. ARTS must be disabled from the KDE Sound System menu.

  9. #9
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    2

    Default Re: artsd eating up cpu in vmare image

    Kmenu > system > settings > sound & multimedia > sound system
    untick "enable sound system"

  10. #10
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    4

    Default Re: artsd eating up cpu in vmare image

    Antoher solution is to disable the sound in VM-Ware. Like this :
    VM -> Settings -> Remove Sound Card

    And at the next reboot the process artsd is OK (less than 1% CPU) ... I think it's a bad parametrage between VM-Ware eand the host to pump up the "bt's musik" at startup.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •