I just applied the latest batch of updates, as the twitter post announced.

Everything went well apart from the Postgresql upgrade, the following error was given.

Setting up postgresql-8.3 (8.3.8-0ubuntu8.10) ...
Starting PostgreSQL 8.3 database server: main* The PostgreSQL server failed to start. Please check the log output:
2009-09-29 12:21:43 BST FATAL: could not load server certificate file "server.crt": No such file or directory
failed!
invoke-rc.d: initscript postgresql-8.3, action "start" failed.
dpkg: error processing postgresql-8.3 (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql:
postgresql depends on postgresql-8.3; however:
Package postgresql-8.3 is not configured yet.
dpkg: error processing postgresql (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
postgresql-8.3
postgresql
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm not conversant with Postgresql and after a bit of google'ing around I cant find a fix.

Anyone else got this problem or does anyone have any pointers or a fix??

Regards
Dave

Done some more Google'ing and found a fix, maybe.

Do we need ssl?, if not just turn off ssl in /etc/postgresql/8.3/main/postgresql.conf

And then /etc/init.d/postrgresql start and it runs

If we need ssl then we need a new certificate, the certs are linked to a snake-oil cert

lrwxrwxrwx 1 root root 36 Jun 22 17:19 server.crt -> /etc/ssl/certs/ssl-cert-snakeoil.pem
lrwxrwxrwx 1 root root 38 Jun 22 17:19 server.key -> /etc/ssl/private/ssl-cert-snakeoil.key

which is not present in the /etc/ssl/certs.

The new certificates can be created by :-

cd /etc/ssl/certs
make-ssl-cert generate-default-snakeoil --force-overwrite

Now retstart postgresql

/etc/init.d/postgresql restart

This should be everything back to life.