Results 1 to 4 of 4

Thread: Fake ap heeeeeeeeeeeeeeeeelp plz

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    13

    Unhappy Fake ap heeeeeeeeeeeeeeeeelp plz

    Hello everyone,lately i have been trying to set up a fake ap,i have an intel 3945 wireless{wlan0} and an alfa usb 500mw {wlan1}.my alfa is the interface connected to my router {192.168.1.254}.Everything goes fine until i try to start a dhcpd3 server on wlan0.I get the following error::


    Sep 27 22:00:08 BT dhcpd: All rights reserved.
    Sep 27 22:00:08 BT dhcpd: For info, please visit ........
    Sep 27 22:00:08 BT dhcpd: Internet Systems Consortium DHCP Server V3.1.1
    Sep 27 22:00:08 BT dhcpd: Copyright 2004-2008 Internet Systems Consortium.
    Sep 27 22:00:08 BT dhcpd: All rights reserved.
    Sep 27 22:00:08 BT dhcpd: For info, please visit ..................
    Sep 27 22:00:08 BT dhcpd: Wrote 0 leases to leases file.
    Sep 27 22:00:08 BT dhcpd: wlan0: unknown hardware address type 803
    Sep 27 22:00:08 BT dhcpd:
    Sep 27 22:00:08 BT dhcpd: No subnet declaration for wlan0 (0.0.0.0).
    Sep 27 22:00:08 BT dhcpd: ** Ignoring requests on wlan0. If this is not what
    Sep 27 22:00:08 BT dhcpd: you want, please write a subnet declaration
    Sep 27 22:00:08 BT dhcpd: in your dhcpd.conf file for the network segment
    Sep 27 22:00:08 BT dhcpd: to which interface wlan0 is attached. **
    Sep 27 22:00:08 BT dhcpd:
    Sep 27 22:00:08 BT dhcpd:
    Sep 27 22:00:08 BT dhcpd: Not configured to listen on any interfaces!


    This is how my /etc/dhcp3/dhcpd.con looks like>>>>>>>>>>>>>>>>>>

    ddns-update-style none;

    option domain-name "thedomain.org";
    option domain-name-servers 192.168.1.254;

    default-lease-time 600;
    max-lease-time 7200;

    authoritative;

    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.70 192.168.1.80;
    option routers 192.168.1.254;
    }

    And this is my /etc/network/interfaces>>>>>>>>>>>>>>>>>>>>

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet dhcp

    auto eth1
    iface eth1 inet dhcp

    auto eth2
    iface eth2 inet dhcp

    auto ath0
    iface ath0 inet dhcp

    auto wlan0
    iface wlan0 inet static
    address 10.0.0.1
    netmask 255.255.255.0
    subnet 10.0.0.0
    broadcast 10.0.0.25

    And i did configure my dhcpd3-server to listen on my wlan0..

    SO PLZZZZZZZZ IF ANYONE COULD HELP I WOULD REALLY APPRECIATE, I'VE BEEN SEARCHING AND TRYING FOR A WEEK BUT USELESSSS!!!!!!!!!!

  2. #2

  3. #3
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    13

    Default

    Hi Lincoln, thnx for ur time man...Well I tried gotmilk's script,with the suggested fixes, everything goes fine until i try to connect with my win xp laptop to my fake ap, i keep on getting limited or no connectivity, i think the problem is with the dhcpd server not assigning an ip,although it says dhcpdiscover-offer 10.0.0.2, but still nothing.........this is driving me crazy



    ANY IDEAS PLZZZ?????????????

  4. #4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •