Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: installazione nvidia-driver

  1. #1
    Junior Member
    Join Date
    Aug 2009
    Posts
    38

    Default installazione nvidia-driver

    ciao a tutti
    scusate la domanda, ma ho provato in molti modi, ma non riesco ad installare questi driver e usare cuda.
    ho usato sia apt-get install nvidia-driver sia direttamente synaptic, ma niente.
    Poi leggendo il tut su cuda si dice di installarli fuori da ambiente X, così ctrl+alt+canc, ed esco da x e do di nuovo il comando apt.
    ma nulla ,mi da sempre errore.
    poi nel menu system trovo NVIDIA X SERVER SETTING, con messaggio just run "nvidiaxconfig" as root. lo faccio reboot, ma non parte più startx. Allora dal menu del boot faccio partire la "console di ripristino" do l'opzione per xserver e al successivo boot startx parte ,ma di usare i driver nvidia non se ne parla.

    ora ho scaricato i driver direttamente da nvidia, con una estenzione pkg1.run
    come li installo
    ciao e grazie

  2. #2
    Moderator
    Join Date
    Aug 2007
    Posts
    1,053

    Default

    il fatto è che si deve fare attenzione altrimenti si entra in un circolo vizioso... :S

    se installi un solo pacchetto nvidia-* poi devi disinstallarlo completamente con tutte le dipendenze, prima di rifare l'installazione.

    se hai scaricato il pacchetto *.run dal sito nvidia, li installi con:

    Code:
    sh ./nomepacchetto
    ma non credere che vada tuto a buon fine se non hai rimosso prima tutti i pacchetti/drivers precedenti.

  3. #3
    Junior Member
    Join Date
    Aug 2009
    Posts
    38

    Default

    ok, grazie
    ma per disinstallare puo bastare synaptic, che mi indica tutte la dipendenze di un programma quando gli si chiede di disinstallare?
    poi per usare il comando che mi hai dato, possofarlo da ambiente x o devo starne necessariamente fuori?
    ciao e ancora grazie

  4. #4
    Moderator
    Join Date
    Aug 2007
    Posts
    1,053

    Default

    tutti i drivers delle schede video si installano sempre e solo da fuori X, anche se sembra, nelle distro di ultima generazione (ubuntu 9.04 ad esempio), i drivers te li installa in X, ma li rende disponibili solo dopo un riavvio.

    per installare puoi usare quello che vuoi ma magari synaptics ti elenca le dipendenze in modo piu semplificato da ricordare.

  5. #5
    Senior Member
    Join Date
    Jan 2009
    Posts
    114

    Default

    Quote Originally Posted by cironte View Post
    apt-get install nvidia-driver
    se non erro questo installa il modulo per il kernel 2.6.30.5.
    se ai la bt4prefinal pulita meglio apt-get backtrack-nvidia che installa tutto il necessario, e poi compili i driver da riga di comando fuori X

    io ho preso i 190.18 cuda da : Download CUDA Code - complete and free toolkit for creating derivative works

    per compilarli sotto 2.6.30.5 è un po piu difficile ci sono i 3d in inglese
    http://forums.remote-exploit.org/bac...ew-kernel.html
    acer 5920g , 345abg , nvidia 8600m
    bt5 kde 64bit + acpi + cuda 4.0 / nvidia 270.40 / pyrit

  6. #6
    Junior Member
    Join Date
    Aug 2009
    Posts
    38

    Default

    ancora non avevo letto i 3th di nemis
    ho disinstallato e reinstallato tutto (cioè questi 3 files dal sito di nvidia)
    cudadriver_2.3_linux_32_190.18.run
    cudatoolkit_2.3_linux_32_ubuntu8.10.run
    cudasdk_2.3_linux.run
    nell'ordine dell'elenco.
    Ora quando parte startx mi da la schermata di nvidia che conferma l'utilizzo dei driver migliori, e nel menu system> nvidia x server setting ora sembra tutto a posto.
    Però non ci sono i tools di cuda (credevo che cudatoolkit servisse proprio per installarli)
    Se invece provo con synaptic l'installazione non va a buon fine perchè c'è il solito problema di
    nvidia-drivers
    installare ore backtrack-nvidia? dopo aver già installato i file suddetti?
    ricomincio tutto da capo?
    ciao e grazie

  7. #7
    Senior Member
    Join Date
    Jan 2009
    Posts
    114

    Default

    io ho fatto all inizio i backtrack-nvidia e poi per ultimi cudadriver_2.3_linux_32_190.18.run


    e ora mi tengo l installazione di cudadriver_2.3_linux_32_190.18.run fin che non escono di nuovi.
    gli altri due non li ho installati. e mi pare giri tutto bene, anzi forse X si carica piu veloce dei 190.18.4
    acer 5920g , 345abg , nvidia 8600m
    bt5 kde 64bit + acpi + cuda 4.0 / nvidia 270.40 / pyrit

  8. #8
    Junior Member
    Join Date
    Aug 2009
    Posts
    38

    Default

    ciao
    scusate, ma cuda toolkit e cuda multiforcer sono presenti nei menu?
    ciao

  9. #9
    Just burned his ISO tex63willer's Avatar
    Join Date
    Jun 2009
    Posts
    8

    Default

    Mi inserisco nella discussione per un problema correlato all'installazione dei driver 190.18 presi dal sito NVIDIA. Precedentemente avevo installati i driver 180.11. Ho seguito le istruzioni del tutorial su CUDA uscendo da xserver e facendo partire l'installazione con sudo sh.... Durante l'installazione chiede anche l'esecuzione di nvidia-xconfig che va a buon fine senza messaggi di errore. Al riavvio di startx compare l'errore:" the nvidia kernel module has version 180.11 but nvidia driver component has version 190.18...." Ho cercato in rete e mi sembra che sia un errore abbastanza frequente, ho provato qualche soluzione consigliata ma non sono ancora riuscito a risolvere il problema. Ora credo di essere entrato in un "circolo vizioso" come giustamente dice brigante. Qualche suggerimento su come uscirne? Grazie

    PS ho fatto tutto questo casino perchè prima avevo provato a installare backtrack-nvidia ma alla fine dell'installazione c'erano due o tre errori (che ora non ricordo) e facendo partire pyrit benchmark c'era l'errore CUDA device: unable to load geforce 9650m GT (o qualcosa di simile). Perciò avevo pensato che mettendo i driver abilitati per CUDA avrei risolto il problema..ma forse ho pensato troppo!

  10. #10
    Moderator
    Join Date
    Aug 2007
    Posts
    1,053

    Default

    apt-get o synaptics e togli tutti i programmi che portano la parola nvidia con tutte le dipendenze, tutte.

    poi esci da X e installi i 180, riavvii e dovrebbe essere tutt' a posto, non devi installare null'altro che porti la parola nvidia con se prima che re/installi i drivers.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •