Results 1 to 2 of 2

Thread: Kernel Upgrade (to 2.6.30.5) broke the ATi Catalyst drivers . . . no graphics

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    24

    Default Kernel Upgrade (to 2.6.30.5) broke the ATi Catalyst drivers . . . no graphics

    Had to completely re-install the original pre-final on an external USB hard-drive on my desktop machine which has a pair of ATi Radeon HD3870 graphics cards . . . after following the Blog instructions about how to upgrade the kernel from 2.6.29.x to 2.6.30.x (which were straghtforward and easy to follow).

    This family of higher end ATi Radeon HD cards *require* the ATi drivers for Xorg to work. Without them, one gets the "Black Screen of Death" shortly after using the "startx" command. Installing BT4 requires booting from the pre-final DVD into "safe graphics" mode to get to the installer script (on the desktop). No download (apt-get install . . . ) of either the ati-driver package or backtrack-ati package would fix it . . . including running the make.sh to recompile the drivers.

    As posted in greater detail in another thread about ATi-Stream . . . the backtrack-ati package has the proper ATi-drivers for ATi-Stream (not the separate ati-driver package which breaks ATi-Stream). The pyrit upgrade also breaks ATi-Stream.

    Until the ATi drivers are fixed for the new kernel and ATi-Stream . . . it's going to have to remain running the 2.6.29.4 kernel. Not that BIG a deal to me . . . but thought I would post this to warn others that have ATi Radeon HD graphics. If someone comes up with a "fix" I can perform for the fglrx (ATi) drivers . . . I'd be very happy . . . as I've exhausted everything I know to do to try to get the required ATi drivers working in the new kernel.

    I know the kernel upgrade is ultimately a Good Thing that will fix a number of other issues . . . a few other things will have to catch up with it to work right.
    John

  2. #2
    Senior Member
    Join Date
    Jan 2009
    Posts
    114

    Default

    may you start with 2.6.29.4, go online and download all the necessary to compile ATI driver (i dont know what file, i have my problem with my nvidia&2.6.30.5 :-D ) then reboot on 2.6.30.5 and try to compile your module / driver offline ?
    acer 5920g , 345abg , nvidia 8600m
    bt5 kde 64bit + acpi + cuda 4.0 / nvidia 270.40 / pyrit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •