Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39

Thread: BackTrack 4 Pre Final Kernel Update

  1. #21
    Junior Member waxlrose's Avatar
    Join Date
    Feb 2009
    Posts
    27

    Default

    How do I or where do I make optimization of an kernel 'CONFIG_HIGHMEM64G' memory option so to expand PAE - addressing capabilities of an 4GB of RAM memory feature. BTW I've never configed kernel yet, but I would be glad if someone could throw some info or guide. thx

  2. #22
    Good friend of the forums Eatme's Avatar
    Join Date
    Aug 2009
    Location
    Socks5
    Posts
    308

    Default

    Quote Originally Posted by Snayler View Post
    Take a snapshot and try the default option. If something goes wrong, revert your virtual machine state to the last snapshot taken.
    Yea i did that even before reading this..lol

    Nothing wrong happen even when choosing the option 23: 2Core or the default one.

    Everything is installed and sorted out, im just stuck on: http://forums.remote-exploit.org/bac...tml#post151650
    Wiffy-Auto-Cracker - was the best thing that ever happen to me. :) Wo0oT :)
    AWUSO36H_500mW_5dBi Antenna

  3. #23
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    8

    Default

    Quote Originally Posted by waxlrose View Post
    How do I or where do I make optimization of an kernel 'CONFIG_HIGHMEM64G' memory option so to expand PAE - addressing capabilities of an 4GB of RAM memory feature. BTW I've never configed kernel yet, but I would be glad if someone could throw some info or guide. thx
    I'll try to make it easy... (Everything as root from the shell)

    1. apt-get install linux-source-2.6.30.5
    2. cd /usr/src
    3. tar xvjf linux-source-2.6.30.5.tar.bz2
    4. cd linux-source-2.6.30.5
    5. zcat /proc/config.gz > .config
    6. make menuconfig
    7. In the menu choose: Processor type and features -> High Memory Support (4GB) -> 64GB, and then exit the program saving the changes when it asks for it
    8. make (And wait... Depending on your computer this may take something between 15 minutes to about an hour. This will create /usr/src/linux-source-2.6.30.5/arch/x86/boot/bzImage and /usr/src/linux-source-2.6.30.5/System.map that you will use with grub so copy them as /boot/vmlinuz-2.6.30.5 and /boot/System.map-2.6.30.5 respectively. You will have to make an entry for them in /boot/grub/menu.lst)
    9. make modules
    10. make modules_install
    11. mkinitramfs -o /boot/initrd.img-2.6.30.5 2.6.30.5
    12. reboot (assuming you made the correct entry for grub you will be able to boot from it)
    13. (from the shell as root) fix-splash

    And everything should be working...

    Check the memory with free, and it should report the amount of RAM you really have.

    Hope it helps

  4. #24
    Junior Member waxlrose's Avatar
    Join Date
    Feb 2009
    Posts
    27

    Default

    Quote Originally Posted by admrt View Post
    I'll try to make it easy... (Everything as root from the shell)

    1. apt-get install linux-source-2.6.30.5
    2. cd /usr/src
    3. tar xvjf linux-source-2.6.30.5.tar.bz2
    4. cd linux-source-2.6.30.5
    5. zcat /proc/config.gz > .config
    6. make menuconfig
    7. In the menu choose: Processor type and features -> High Memory Support (4GB) -> 64GB, and then exit the program saving the changes when it asks for it
    8. make (And wait... Depending on your computer this may take something between 15 minutes to about an hour. This will create /usr/src/linux-source-2.6.30.5/arch/x86/boot/bzImage and /usr/src/linux-source-2.6.30.5/System.map that you will use with grub so copy them as /boot/vmlinuz-2.6.30.5 and /boot/System.map-2.6.30.5 respectively. You will have to make an entry for them in /boot/grub/menu.lst)
    9. make modules
    10. make modules_install
    11. mkinitramfs -o /boot/initrd.img-2.6.30.5 2.6.30.5
    12. reboot (assuming you made the correct entry for grub you will be able to boot from it)
    13. (from the shell as root) fix-splash

    And everything should be working...

    Check the memory with free, and it should report the amount of RAM you really have.

    Hope it helps
    many thx

  5. #25
    Just burned his ISO
    Join Date
    Sep 2009
    Posts
    1

    Default Not picking up the right kernel file

    When I run

    apt-get update
    apt-get install -d linux-image

    and then
    cd /var/cache/apt/archives/

    I don't have a file labeled

    linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb

    The files that are there are all 2.6.27...

    It would appear that I'm not pointed at the right repositories. I haven't changed the /etc/apt/sources.list file. It has the following entries (system won't let me post urls yet so forgive the kludge):
    deb http:<slashslash>archive.offensive-security.com pwnsauce main microverse macroverse restricted universe multiverse
    deb http:<slashslash>archive.ubuntu.com/ubuntu/ intrepid main universe
    #deb http:<slashslash>archive.offensive-security.com/repotest ./
    Output of uname -a:
    Linux vbox-bt4pr 2.6.29.4

    Any suggestions would be appreciated.

    /txb/

  6. #26
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    10

    Default

    thanks a lot
    work fine for me ...

  7. #27
    Just burned his ISO
    Join Date
    May 2009
    Posts
    16

    Default Nvidia driver

    Quote Originally Posted by Barry View Post
    Yaaaay! Back to no working video!!!
    I have a Nvidia 8600gt 256m and i installed the driver from the driver auto update and now i can't startx no configurable screen i says i think i was the 180 driver any ideas why it wont load it?

  8. #28
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    Quote Originally Posted by hellmonger View Post
    I have a Nvidia 8600gt 256m and i installed the driver from the driver auto update and now i can't startx no configurable screen i says i think i was the 180 driver any ideas why it wont load it?
    Most likely because the driver has been compiled with an older version of the kernel.
    Same happened with the ATI driver. I'll be working on the ATI driver this weekend to get the newest version running with the 2.6.30.5 kernel.
    Tiocfaidh ár lá

  9. #29
    Just burned his ISO
    Join Date
    May 2009
    Posts
    16

    Default

    Quote Originally Posted by KMDave View Post
    Most likely because the driver has been compiled with an older version of the kernel.
    Same happened with the ATI driver. I'll be working on the ATI driver this weekend to get the newest version running with the 2.6.30.5 kernel.
    i did a fresh install updated kernel, updated, installed kubuntu-desktop updated to 9.04 did the updates then it told me to install the 180 driver and now wont startx.

  10. #30
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Post

    Quote Originally Posted by hellmonger View Post
    I have a Nvidia 8600gt 256m and i installed the driver from the driver auto update and now i can't startx no configurable screen i says i think i was the 180 driver any ideas why it wont load it?
    edit the xorg.conf file.
    and try with these settings
    option "UseEDID" "False" to "True"
    Tested on my nvidia 9200GS using 2.6.30.5 compiled kernel having Nvidia 185 version binary drivers.also check with the xorg & nvidia log for detail diagnosis.

    if all fails and still not avail.there are 2 methods-
    open /etc/X11/xorg.conf and
    replace in the driver section
    "nvidia"
    to
    "nv"

    method 2:
    copy xorg.conf.back(up) and replace with xorg.conf
    you will be having working X session

Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •