Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Dell Inspiron 1545

  1. #1
    Member
    Join Date
    Dec 2007
    Location
    The Netherlands
    Posts
    267

    Default Dell Inspiron 1545

    This topic is a work in progress as I'm still setting up backtrack, but I will add as I learn.

    First the specs:
    P8600 4 GB 500 GB (not too important)

    Ati mobility radeon 4330
    Intel WiFi Link 5100 (802.11 a/b/g/n 1x2) Half minicard
    Dell Wireless 365 Bluetooth-module
    Creative 1.3 MP webcam
    15,6-inch WXGA WLED (1.366 x 768) screen
    Alps touchpad


    First off, I am happy to tel you that the 2 meter power cord works flawless with backtrack.
    Now onto the more serious stuff, I had to do some tweaking to get X to work. No matter what boot option I used (aside from vga=xxx), the system would flash, and report no screens found. The solution lied in booting in safe mode, and replacing the default xorg with the preconfigured xorg-vesa (in the same directory).

    The touchpad worked fine as far as I could see.


    My next challenge lies at getting wifi to work. The card is recognised and detects my wpa2 network, but says encryption is not enabled (same story with my Alfa awus036H). I assume I have to start a background service somewhere, which I will look into.

    Update: Wireless works, the trick was to start the wicd deamon, and then use the advanced tab to enable encryption.

    Update 2: Ati driver. don't install the fglrx, that will fail the dkms, just use apt-get install backtrack-ati and it will do the rest!

    Will be updated whenever I get something to work or bork it.

  2. #2
    Junior Member
    Join Date
    Jan 2010
    Posts
    81

    Default

    For your Alfa card, you need to use ndiswrapper for WPA{2}. Here is a tutorial by Tron:
    Code:
    http://forums.remote-exploit.org/backtrack3-howtos/15497-auto-ndiswrapper-getting-wpa-wpa2-support-awus036h-managed-mode-5.html

  3. #3
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    Quote Originally Posted by redhotfire View Post
    For your Alfa card, you need to use ndiswrapper for WPA{2}. Here is a tutorial by Tron:
    Code:
    http://forums.remote-exploit.org/backtrack3-howtos/15497-auto-ndiswrapper-getting-wpa-wpa2-support-awus036h-managed-mode-5.html
    You do realise that tutorial is for older driver known as r8187 which can't handle wpa2 let alone wpa?

    On BT4pf the driver is rtl8187 and it should be able to handle WPA. I have tried it on WPA-TKIP and it works without the need to use ndiswrapper.

  4. #4
    Member
    Join Date
    Mar 2010
    Location
    /dev/null
    Posts
    455

    Default

    Quote Originally Posted by Citruspers View Post
    No matter what boot option I used (aside from vga=xxx), the system would flash, and report no screens found.
    Boot options aren't related to the X server (except noacpi & some other stuffs). If you do want something convenient then install ati drivers...

    Quote Originally Posted by Citruspers
    On BT4pf the driver is rtl8187 and it should be able to handle WPA. I have tried it on WPA-TKIP and it works without the need to use ndiswrapper.
    WPA-TKIP isn't WPA2 : the first one is a kind of WEP enhancement, the second one is something completely new... All wifi cards can't handle WPA2 (even if they could handle WPA). But what about the drivers ? Lots of issues are reported with WPA2 support... I'm not sure that backtrack's rtl8187 drivers would actually support it...

  5. #5
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    Quote Originally Posted by ~LCF~ View Post
    WPA-TKIP isn't WPA2 : the first one is a kind of WEP enhancement, the second one is something completely new... All wifi cards can't handle WPA2 (even if they could handle WPA). But what about the drivers ? Lots of issues are reported with WPA2 support... I'm not sure that backtrack's rtl8187 drivers would actually support it...
    I know WPA-TKIP isn't WPA2, WPA still requires handshake which still makes WPA-TKIP not as easy to attack. I'm just saying that rtl8187 does support WPA-TKIP, the latter WPA2 is generally WPA-PSK with AES encryption iirc.

  6. #6
    Member
    Join Date
    Mar 2010
    Location
    /dev/null
    Posts
    455

    Default

    Please take it easy, I was not saying you didn't know that, I just noticed here and there some issues concerning WPA2 with those drivers (rtl8187). What I wrote about the difference between the two WPA encryption was there to explain why some cards can connect to WPA2 APs whereas others can't even if they can connect to WPA-TKIP APs. Once again, I didn't mean that's a thing you don't know, but other readers might not.

  7. #7
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    2

    Default enabling the wireless radio

    i just got a dell inspiron 1545, and i've been trying to get it connected to my WPA-TKIP network, but i can't figure out how to enable the wireless radio, or if it's enabled, how to get it to scan for my AP.

    suggestions?

  8. #8
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    Quote Originally Posted by ~LCF~ View Post
    Please take it easy, I was not saying you didn't know that, I just noticed here and there some issues concerning WPA2 with those drivers (rtl8187). What I wrote about the difference between the two WPA encryption was there to explain why some cards can connect to WPA2 APs whereas others can't even if they can connect to WPA-TKIP APs. Once again, I didn't mean that's a thing you don't know, but other readers might not.
    No harm taken, was just taken aback for a moment.

    Quote Originally Posted by cjonbe
    i just got a dell inspiron 1545, and i've been trying to get it connected to my WPA-TKIP network, but i can't figure out how to enable the wireless radio, or if it's enabled, how to get it to scan for my AP.

    suggestions?
    There is a button on the laptop, press it, if you still do not see a wireless interface, the next step I suggest is to boot the kernel with acpi=off.

  9. #9
    Just burned his ISO mr-swaggmore's Avatar
    Join Date
    Aug 2009
    Posts
    19

    Default

    you have to open wicd click on the tab beside your network name this will bring up a menu with <advanced settings> click on that then select <use encryption> then select your network type wpa,wep,etc then enter your passphrase hope this helps.

    btw did start wicd </etc/init.d/wicd start>
    D-Day 2012 fact or fiction

  10. #10
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    2

    Default

    mr-swaggmore, i was not running wicd. that seems to have gotten that at least. now i have to troubleshoot.

    hatake_kakashi, no indicator pops up when i push the wireless radio button.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •