Results 1 to 7 of 7

Thread: Airmon-ng show nothing - TP Link WN821

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    2

    Exclamation Airmon-ng show nothing - TP Link WN821

    Hello Everyone.
    after couple of days searching the web i gave up finding the answer to my problam alone.

    ok so here is the detail:
    i got TP link WN821 wireless card, used windows 7 and windows xp with VmWare Workstation 7.0.1 build-227600, and the VMWare verision of back track 4 final.

    i did everything just like the tutorials but when i press airmon-ng it doesnt show anything - give me no options, i disabled the windows wireless card and it was only enabled on the VmWare, Vmware says it identify the wirless card and its connected to it but the airmon-ng command doesnt show any options. when i press IWCONFIG i see 2 options lo and eth0 (they both written to have no wireless)

    i searched almost everywhere on the web, and i even downloaded the regular verision of back track burned it and started it as live cd but still it wont work.

    CAN ANY1 PLS HELP ME WITH THIS PROBLAM?

    by the way i saw that the usb wireless card im using is supported so i dont think thats the problam.


    Thanks alot for whoever can help me !!!

  2. #2
    Member
    Join Date
    Jan 2010
    Location
    Helsinki, Finland
    Posts
    235

    Default Re: Airmon-ng show nothing - TP Link WN821

    havy you successfully connected your wireless cart to virtual machine. What does tell, post output here
    Code:
    iwconfig
    ifconfig
    lsusb

  3. #3
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    2

    Default Re: Airmon-ng show nothing - TP Link WN821

    iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:10 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:500 (500.0 B) TX bytes:500 (500.0 B)

    lsusb
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 0cf3:1002 Atheros Communications, Inc.

    thanks for the help

  4. #4
    Junior Member
    Join Date
    Feb 2010
    Posts
    34

    Default Re: Airmon-ng show nothing - TP Link WN821

    Virtual Machine for some reason dosent work well for 7. I was using Virtual Machine with Alfa and i coudlnt connect and when i finally got my Alfa to connect i started to have the same problem your having. I had a hell of a time to get my Alfa to connect. I had to unplug and replug over and over and reboot..Got old fast. The only thing you can do is to just play around with it. Check your VM network settings. Plug in your card after KDE or do a cache dump. As of now i will never go back to VM
    Sony LapTop Windows 7 - Backtrack ISO with Sun VirtualBox - ALFA AWUS036H USB 500MW

  5. #5
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    13

    Default Re: Airmon-ng show nothing - TP Link WN821

    There are two versions of this adapater 1 and 2. If you got two like me, I feel for you man. Been searching for days on how to get the prick working.

    See how in you iwconfig no wireless adapters are shown, thats because if you got the V2, it actually is not supported. I know.

    I eventually did find this: http://www.backtrack-linux.org/forum...r-working.html

    The funny thing is I used the search engine on this site to search for this very thing and came up zilch, did my own browsing into the depths and found it, says allot about the algorithms they got running. Anyway it's simple to follow all you have to do is compile and then install the driver pack and copy some files in the appropriate dir.

    This will help you to get backtrack to recognize your device, the problem is now that I can't turn it on. I have already made a thread in this forum asking someone how to turn it on, but I got a suspicion that it is not going to work because I already tried to turn it on using the appropriate commands but still not working. Gonna have to wait and see.

    P.s.

    You might find doing it through VM could cause you some issues and using the live cd wont work if you are installing stuff, so your only option is to install onto a HDD.

  6. #6
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    2

    Default Re: Airmon-ng show nothing - TP Link WN821

    I have Windows 7, and use dvd backtrack 4, and virtual machine. I am not sure where exactly I need to download the drivers, and which command I have to run in order that airmon-ng command shows some results.

    Thanks in advance...

    waiting...

  7. #7
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    2

    Cool Re: Airmon-ng show nothing - TP Link WN821

    Hi, I have T-LINK adapter as well WN821, and Windows 7, BACKTRACK on DVD, and Virtual MAchine installed, I use the commnand : airmon-ng in Backtrack, nothing returns.
    What exactly I need to download and where to install on my PC?

    Thanks in advance...

Similar Threads

  1. how to show or work folder home
    By zerohour in forum Beginners Forum
    Replies: 6
    Last Post: 03-15-2010, 11:48 PM
  2. Little help with airmon-ng start wlan0
    By sneja in forum Beginners Forum
    Replies: 3
    Last Post: 03-01-2010, 06:27 PM
  3. Can someone please teach me about airmon-ng?
    By riomaru in forum Beginners Forum
    Replies: 2
    Last Post: 02-16-2010, 02:30 AM
  4. bt4 iso on vmware but wireless card doesnt show up?
    By christian666 in forum Beginners Forum
    Replies: 6
    Last Post: 02-11-2010, 11:30 PM
  5. WiFi should work , but doesn't even show up : HELP !
    By lilspanyol in forum Beginners Forum
    Replies: 4
    Last Post: 01-18-2010, 03:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •