Hello. I am having a hard time upgrading. I run sudo apt-get update and I get this:
Get:1 mirrors.kernel.org sid Release.gpg [835B]
Ign mirrors.kernel.org sid/main Translation-en_US
Get:2 mirrors.kernel.org sid Release [104kB]
Ign mirrors.kernel.org sid Release
Hit mirrors.kernel.org sid/main Packages
Hit SUN Backtrack Linux Repository pwnsauce Release.gpg
Ign SUN Backtrack Linux Repository pwnsauce/main Translation-en_US
Hit Index of / intrepid Release.gpg
Ign Index of / intrepid/main Translation-en_US
Ign SUN Backtrack Linux Repository pwnsauce/microverse Translation-en_US
...
Hit Index of / intrepid/restricted Sources
Hit Index of / intrepid/universe Sources
Fetched 836B in 1s (694B/s)
Reading package lists... Done
W: GPG error: mirrors.kernel.org sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9AA38DCD55BE302B
W: You may want to run apt-get update to correct these problems

When I try apt-get install, I get this:
sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc-dev-bin: Depends: libc6 (> 2.10) but 2.8~20080505-0ubuntu9 is installed
Recommends: manpages-dev but it is not installed
libc6-dev: Depends: libc6 (= 2.10.2-6) but 2.8~20080505-0ubuntu9 is installed
E: Unmet dependencies. Try using -f.

Trying apt-get -f install doesn't work. Trying to upgrade from root doesn't work.
Trying apt-get install libc6 results in this:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6: Depends: libc-bin (= 2.10.2-6) but it is not going to be installed
libc6-i686: PreDepends: libc6 (= 2.8~20080505-0ubuntu9) but 2.10.2-6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

And finally, completing the loop, apt-get install libc-bin results in:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc-bin: Breaks: libc6 (< 2.10) but 2.8~20080505-0ubuntu9 is to be installed
libc-dev-bin: Depends: libc6 (> 2.10) but 2.8~20080505-0ubuntu9 is to be installed
Recommends: manpages-dev but it is not going to be installed
libc6-dev: Depends: libc6 (= 2.10.2-6) but 2.8~20080505-0ubuntu9 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Any advice would be greatly appreciated.