Results 1 to 9 of 9

Thread: wicd connection problem

  1. #1
    Junior Member
    Join Date
    Feb 2008
    Posts
    33

    Angry wicd connection problem

    Hi can anyone tell why i can not connect to wireless network using wicd, i ubuntu 9.04 on my laptop and it connect to internet very easy and good, but when i try on bt4 pre final i put the web key and it keep trying to connect but can not able to go on line i don't like that wicd is there any network that i can install and use it

  2. #2
    Just burned his ISO aliceinwire's Avatar
    Join Date
    Mar 2008
    Posts
    11

    Default

    Quote Originally Posted by mahabad1972 View Post
    Hi can anyone tell why i can not connect to wireless network using wicd, i ubuntu 9.04 on my laptop and it connect to internet very easy and good, but when i try on bt4 pre final i put the web key and it keep trying to connect but can not able to go on line i don't like that wicd is there any network that i can install and use it
    same problem here i think is a dhcp problem
    try to insert it manually

  3. #3
    Junior Member waxlrose's Avatar
    Join Date
    Feb 2009
    Posts
    27

    Default

    Same issue, have anyone solved it???

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    One failure to provide adequate information is not going to get anyone real help.
    Two, try using the command line for a change.
    That's where the power is at. It will generally also be more reliable.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  5. #5
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    13

    Default

    I had same problem and i solved in that way :

    nano /etc/network/interfaces

    auto lo
    iface lo inet loopback

    leave only that infos in the fila and save.

    Then :
    1)startx;
    2)Services --> Start Network;
    3)Internet --> Wicd;
    4) connect to your wifi.....try different wpa_supplicant options in wicd if you cant connect;
    5) if dont work, try reinstalling wpa_supplicant package;
    6) check in your syslog what appening when you connect and post here if you still have problems.

    I finally added wicd to my startup services, so when i do startx my connection is ready to use. Hope that help....

    Larika

  6. #6
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    You can use commands at the command line to get the internet going:

    Linux Internet Connection - Virjacode
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

  7. #7
    Junior Member waxlrose's Avatar
    Join Date
    Feb 2009
    Posts
    27

    Default

    Quote Originally Posted by Larika View Post
    I had same problem and i solved in that way :

    nano /etc/network/interfaces

    auto lo
    iface lo inet loopback

    leave only that infos in the fila and save.

    Then :
    1)startx;
    2)Services --> Start Network;
    3)Internet --> Wicd;
    4) connect to your wifi.....try different wpa_supplicant options in wicd if you cant connect;
    5) if dont work, try reinstalling wpa_supplicant package;
    6) check in your syslog what appening when you connect and post here if you still have problems.

    I finally added wicd to my startup services, so when i do startx my connection is ready to use. Hope that help....

    Larika
    Don't have any clue how this guide above, helped you but the thing is that I can't make it work from wicd...it keeps trying and trying to connect and every time it reports dhcp unavailabilty from router or in other words it can't obtain an ip address.
    I CAN solve it from bash-cmd, but that won't solve the the wicd issue!

  8. #8
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    6

    Default

    It may be easier to use command line.

    type

    iwconfig wlan0 essid your-essid-here mode managed key XX:XX:XX:XX

    key can be in both hex or ascii, followed by

    dhclient wlan0


    you should get an address from you router/dhcp server confirm with

    ping google.com

    Hope this helps.

  9. #9
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    16

    Default

    I'm seeing this issue as well.
    When in command line before starting up wicd service/client I can do dhclient and I get an ip instantly. When I start up wicd service/client I then do dhclient and it keeps looping through DHCPdiscovery and it times out getting an ip address. It does the same when using wicd to get the ip.

    It used to work in BT4 beta.

    I guess the answer is cli and wpa_supplicant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •