Results 1 to 6 of 6

Thread: Eth0 connects to router but does not connect to Internet

  1. #1
    imported_MadHatter
    Guest

    Default Eth0 connects to router but does not connect to Internet

    Hello,

    I have been trying to get any sort of networking to run for the past 3 weeks trying every tutorial and how to on the web and these forums to no success. I am trying to get the ethernet to work on my netbook. I have set up a connection to the router, but that is as far as i get. I can connect to 192.168.1.1 and change the configurations on my router, but when I try google or anything else, i am not connected. Suprisingly I was looking at my ifconfig and i noticed that my eth0 has both ipv4 and ipv6,

    Ifconfig eth0
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:23:8b:d9:e1:b6
              inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::223:8bff:fed9:e1b6/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:964 errors:0 dropped:0 overruns:0 frame:0
              TX packets:766 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:205766 (205.7 KB)  TX bytes:62703 (62.7 KB)
              Interrupt:26 Base address:0x8000
    I am not really sure what to try next.

    Any help is appreciated,
    Thanks

  2. #2

    Default

    it would be helpful if you told us what version of backtrack you are using.
    Until they become conscious they will never rebel, and until after they have rebelled they cannot become conscious...

  3. #3
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default

    Id check that Backtrack has a default gateway defined (the router should be the gateway - use the "route" command to check) and that it has a DNS server defined (again as the router - "cat /etc/resolv.conf").

    If you are getting the address for the eth0 on BackTrack from DHCP these should have been automatically setup for you, if you set it manually you will need to set the gateway and DNS server yourself.

    If those are OK then the issue could be a number of other things, including level 2 or level 3 filtering on the router and NAT on the router.

    It sounds like you have a generic TCP/IP troubleshooting issue though, so if the router and DNS server ideas dont bear fruit Id start by learning more about TCP/IP and how it works.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  4. #4
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    Here's a tutorial on setting your Linux internet connection:

    Linux Internet Connection - Virjacode
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

  5. #5
    imported_MadHatter
    Guest

    Default

    Lupin,

    Thank you so much, you were right, I just needed to put the nameserver xxx.xxx.xxx.xxx into the resolv.conf file. Thanks for the help.

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    1

    Default

    How to set up ip Backtrack 4 permanently, so every reboot or shutdown no longer set ip again!

    If anyone can help me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •