Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Intel Wifi link 5100 (Lenovo X200T)

  1. #1
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    1

    Default Intel Wifi link 5100 (Lenovo X200T)

    It appears there are some growing pains with this card and certain kernels causing lots of headaches. There was a good post over at the Aircrack-ng forums that suggested to replace three files..

    drivers/net/wireless/iwlwifi/iwl-agn.c
    drivers/net/wireless/iwlwifi/iwl-sta.c
    drivers/net/wireless/iwlwifi/iwl-tx.c

    related posts:
    hxxp://forum.aircrack-ng.org/index.php?topic=4217.0]Intel Wireless Wi-Fi 5100 Card injection OK

    hxxp://git.kernel.org/?p=linux/kernel/git/linville/wireless-testing.git;a=commit;h=84e8e77f618f589316e83dfa1bf afe5a47bf0bd2]git.kernel.org - linux/kernel/git/linville/wireless-testing.git/commit

    Simply replacing those files fixed all my issues with the iwl5100

  2. #2
    Junior Member
    Join Date
    Apr 2010
    Posts
    37

    Default

    can you inject now ?

  3. #3
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    10

    Default

    ive seen that post over and over, can you explain exactly what you did step by step?
    there are a bunch of people who have been pulling out hair over this card.

    thanks so much

  4. #4
    Member
    Join Date
    Feb 2007
    Posts
    229

    Default

    That fix was applicable to an earlier kernel, how in the world did you get it to work with this one? Wonder if the new kernel works "out of the box" with this BLOODY CARD.

  5. #5
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    13

    Default

    I got the Backtrack 4 Pre-Final and i want to make my 5100agn inject to do these steps all count for me too?

  6. #6
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    8

    Default

    So your Intel Link 5100 scans fine, etc? What chipset is the 5100 based on?

  7. #7
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    Quote Originally Posted by poccnr View Post
    So your Intel Link 5100 scans fine, etc? What chipset is the 5100 based on?
    Its an intel chipset :P intel a/g/n.

  8. #8
    Just burned his ISO
    Join Date
    Sep 2009
    Posts
    1

    Default

    i'm with ibm t400 with intel5100agn using driver iwlagn still not tested on injecting but airdump and aircrack work.

  9. #9
    Member zWiReDz's Avatar
    Join Date
    Sep 2009
    Posts
    123

    Default

    Quote Originally Posted by valko View Post
    i'm with ibm t400 with intel5100agn using driver iwlagn still not tested on injecting but airdump and aircrack work.
    Aircrack-ng doesn't use your wireless card silly..
    "If it's stupid but works, it's not stupid." - Murphy's Laws of combat, #2

  10. #10
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    3

    Default

    i have the 5100 agn. i can confirm that injection is NOT working out the box as some stated. weird but the simple injection test (aireplay-ng -9 interface) says its working. im a newbie to linux so there could be something that im missing.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •