Results 1 to 2 of 2

Thread: apt-get problem

  1. #1
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    1

    Default apt-get problem

    Hi,

    I hope that i am putting this in the correct forum. I have installed BT 4.0 on my netbook. I have installed a vodafone mobile connect application for my Vodafone modem.

    This seems to be working ok, but i had to use a .deb package to install it correctly. This seems to have broken apt-get with the following error:-

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    vodafone-mobile-connect: Depends: usb-modeswitch (>= 0.9.7) but 0.9.6 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    If i run the suggested fix, it removes the mobile connect package. Is there any way i can tell apt-get to stop doing this?

    Again sorry for the dumb arse question.

    Thanks

    Simon

  2. #2
    Just burned his ISO
    Join Date
    Sep 2009
    Posts
    1

    Default

    Hi Simon,

    The reason you are seeing that problem is because you need to download the USB modeswitch package as well as the VMC package you already have.

    You can download all the relevant files from the Vodafone betavine site:

    h**ps://forge.betavine.net/frs/?group_id=12

    You can install the .deb packages by using

    Code:
    dpkg -i usb-modeswitch_0.9.4-1_i386.deb
    dpkg -i vodafone-mobile-connect_1.99.17-8_all.deb
    After running both of those commands you may have broken dependencies. To fix them (sudo or run as root):

    Code:
    apt-get -f install
    That should get the USB version running for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •