Results 1 to 4 of 4

Thread: vmware server modules patched for linux-2.6.32-rc4.

  1. #1
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default vmware server modules patched for linux-2.6.32-rc4.

    Hey guys,

    I've had to patch those pesky vmware modules again so they would compile on my new kernel build.

    If anybody need then I thought I'd post them here. Just delete everything in /usr/lib/vmware/modules/source/* and extract my new modules to that folder and run

    Code:
    vmware-config.pl
    There are still lots of warnings but these modules compile and work fine on my box.

    You can download both the patched modules and the patch from the following link.

    vmware server modules patched modules and diff

    Enjoy

  2. #2
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    Hey guys,

    Just a follow on from the original post, I've had a couple of emails regarding building the vmware kernel modules using ubuntu. Apparently vsock still fails ?? I've had no feedback here but a few downloads so I'l add this patch for anyone that see's

    Code:
    vsock: no symbol version for VMCIDatagram_Send
    vsock: Unknown symbol VMCIDatagram_Send
    vsock: no symbol version for VMCI_GetContextID
    vsock: Unknown symbol VMCI_GetContextID
    vsock: no symbol version for VMCIDatagram_DestroyHndvsock
    vsock: Unknown symbol VMCIDatagram_DestroyHnd
    vsock: no symbol version for VMCIDatagram_CreateHnd
    vsock: Unknown symbol VMCIDatagram_CreateHnd
    When trying to load the vsock module. This patch is for vmware-config.pl located in the /usr/bin directory. Just patch up that file and rerun vmware-config.pl and all should be fine. Let me know how you get on peops !!!!!!!!

    You can use the same link in the first post as I've added it to that folder on mediafire.

    Enjoy

  3. #3
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default vmware workstations 7 modules patch for kernel's < 2.6.29

    Hey again,

    Just migrated to vmware workstations 7, and same shiznit. Modules are a pain to compile

    anyway I've included my workstations patch into the vmware folder, Enjoy

    VMware modules patch for kernel's < 2.6.29

    If you downloaded in the first 5 mins of posting, you have the wrong patch hehehe !! I know I'm sloppy

  4. #4
    Just burned his ISO
    Join Date
    Nov 2009
    Posts
    1

    Default

    Your modules works fine on a Mandriva 2010 Powerpack. Thank's a lot for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •