I have this new TP-WN821N WL Adapter with a Atheros. It says that it is supported and that the driver ar9170usb is already included in the release. So naturally I dug deeper it turns out that the V2 of my device is not supported. So that lead me to think I had V2. I looked in devicemgmt to find out nothing really except I had firmware V1.06 which does not tell me allot about the device its self, if maybe someone could point me in the direction to look at the device version that could help me solve this problem. I also installed compat-wireless-2010-02-01 and when I looked inside the usb.c directory it showed my device model number, ID and that V2 was infact supported. I am not to sure what screens I could show, so just ask and I will produce.