Results 1 to 9 of 9

Thread: installing vmware tools bt4 pre -final

  1. #1
    Member
    Join Date
    Nov 2008
    Posts
    62

    Default installing vmware tools bt4 pre -final

    1) mounted the bt4 cd and copied vmwaretools from the cd to a /tmp/ directory

    2) successfully decompressed the tarball and got a new folder named vmware-tools-distrib

    3)navigated to the vmware-tools-distrib folder and found the file, vmware-install.pl

    4) unfortunately, here I'm stuck--typing " vmware-install.pl" at the root command prompt only results in an error "command not found"


    what did i do wrong? why didnt the .pl file execute? Isnt there a perl interpreter in this bt4 release?

  2. #2
    Just burned his ISO theluddite's Avatar
    Join Date
    Dec 2008
    Posts
    13

    Default

    Quote Originally Posted by bwana View Post
    1) mounted the bt4 cd and copied vmwaretools from the cd to a /tmp/ directory

    2) successfully decompressed the tarball and got a new folder named vmware-tools-distrib

    3)navigated to the vmware-tools-distrib folder and found the file, vmware-install.pl

    4) unfortunately, here I'm stuck--typing " vmware-install.pl" at the root command prompt only results in an error "command not found"


    what did i do wrong? why didnt the .pl file execute? Isnt there a perl interpreter in this bt4 release?
    Did you try "perl vmware-install.pl" ? Or "./vmware-install" ?

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by bwana View Post
    1)
    4) unfortunately, here I'm stuck--typing " vmware-install.pl" at the root command prompt only results in an error "command not found"
    As post number two mentions go with ./ or perl
    this will the otherwise useless words above into a command.
    Once that is done go ahead and post back your success.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #4
    Member
    Join Date
    Nov 2008
    Posts
    62

    Default

    ./ seems to work

    It asked several questions with default answers provided in brackets - like-
    Into which directory do you want to install the binary files?
    [/usr/bin]

    I just hit enter and accepted the defaults. After seven questions, it said VMWare Tools e.x.p build 116369 for Linux completed successfully....
    Before running VMware Tools for the first time, you need to configure it by invoking the command : "/usr/bin/vmware-config-tools.pl". I hit return and let it invoke the command.

    Then it said None of the pre-built vnnemctl modules for VMware Tools is suitable for your running kernel. Do you want this program to try to build the vmmemctl module for your system? I hit return and it extracted the sources and started the build . It gave a WARNING Symbol version dump /usr/src/Linux-source-2.6.29.4/Module.symvers is missing; modules will have no dependencies and modversions. It then gave a bunch of errors (error 1 , error 2 unfortunately there is no cpy/paste and i cant even save the history of the konsole to print here) and it concluded cannot build the vmmemctl module.

    In similar fashion it failed to build the vmhgfs module, the vmxnet module, the vmblock module, the vmci module

    As instructed, I logged out and logged back in and invoked
    vmware-toolbox

    This brought up a control panel for vmware tools. I still have no shared folders but now I have copy/paste between BT4 and the mac. So there is no way for me to get the patch vmware-tools-patch-backtrack4-7.8.5-2_6_29 from my mac's hd to bt4 - it doesnt see the shared folder. I dont know where to go from here.

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by bwana View Post
    So there is no way for me to get the patch vmware-tools-patch-backtrack4-7.8.5-2_6_29 from my mac's hd to bt4 - it doesnt see the shared folder. I dont know where to go from here.
    I am not sure about shared folders, I have never gotten it to work nor did I ever really try to.
    As for the patch download it within your vm image itself or use a usb stick to transfer it over or open up ftp on the local host and move it that way.
    If you can copy and paste then you could use it as a method to?
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  6. #6
    Member
    Join Date
    Nov 2008
    Posts
    62

    Default

    good pickup--you noticed that before I installed vmware tools i had no cpy/pst but after that partially successful installation, I gained that functionality. I still wonder why those modules didnt compile. Should i reinstall vmware tools and post the entire output of the konsole here?

    the thing i noticed-system->settings->shared folders brings up a dialog that says sharing services not installed. it tried to dl the necessary packages but of course since the macbook wireless card is not recognized I cant get them. So now i have to get an ethernet cable to hook up my laptop to the net. (Will ethernet cables become as archaic as ps/2 and parallel ports?)

  7. #7
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by bwana View Post
    good pickup--you noticed that before I installed vmware tools i had no cpy/pst but after that partially successful installation, I gained that functionality. I still wonder why those modules didnt compile. Should i reinstall vmware tools and post the entire output of the konsole here?
    You could try that, or if you don't want to work for it/learn anything/or are just in a hurry. You could try out the vmware image from the team
    Offensive Security Training Free Videos and Tutorials
    look at the bottom half of the page and there is a link for it with the md5sum.
    They probably have already installed the tools for you.
    If not there is a post on how to do it on the blog there as well.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  8. #8
    Member
    Join Date
    Nov 2008
    Posts
    62

    Default

    of course i'd rather 'work for it'. bt4 is ubuntu based so package updates should be trivial. i'll check out the blog.

  9. #9
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    1

    Default vmware-config.pl not starting

    Make sure to chmod +rwx (or +755) vmware-file.pl after your unpack the files.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •