I have a Acert 10.1 Aspire One Netbook

I decided to try out the BackTrack 4 Pre Finale and discovered it had Airpwn-1.4 build in. So I copied the conf & content folders from a Airpwn-1.3 file I had to the desktop and decided to run

"airpwn -c conf/greet_html -d ath5k -i mon0 -vvvv"

It starts scrolling mad crazy a bunch of stuff such as

....
data packet len: 166, flags: 66 <-- DS
probe response (MPCS-Open)
probe response (MPCS-Open)
beacon frame (MPCS-Open)
data packet len: 145, flags: 66 <-- DS
null function
acknowledgement
data packet len: 134, flags: 66 <--DS

So I go to another computer and go to google for example and it does nothing. In fact the other computer gets disconnected from the MPCS-Open network.

When I do just ifconfig I get

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scrope:Host
UP LOOPBACK RUNNING MTU 16436 METRIC:1
RX packets:208 errors:0 dropped:0 overruns:0 frame:0
TX packets:208 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txqueuelen:0
RX bytes:12704 (12.7 KB) TX bytes:12704 (12.7 KB)

mon0 Link ecnap:UNSPEC HWaddr 00-24-2B-85-70-8B-30-30-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 141895 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
coallisions:0 txqueuelen:1000
RX bytes:3162753 (31.6 MB) TX bytes:0 (0.0 B)

wlan0 Link ecnap:UNSPEC HWaddr AA-BB-CC-DD-EE-FF-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 294497 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
coallisions:0 txqueuelen:1000
RX bytes:57683186 (57.6 MB) TX bytes:0 (0.0 B)

wmaster0 Link ecnap:UNSPEC HWaddr AA-BB-CC-DD-EE-FF-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
coallisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

and when I do iwconfig I get

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEE 802.11bg Mode:Monitor Frequency:2.437GHz Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Encryption keyff
Power Management: off
Link Quality:0 Signal Level: 0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 invalid misc:0 Missed beacon:0

mon0 IEE 802.11bg Mode:Monitor Frequency:2.437GHz Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Encryption keyff
Power Management: off
Link Quality:0 Signal Level: 0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 invalid misc:0 Missed beacon:0

What am I doing wrong??