Results 1 to 10 of 13

Thread: Wireless for ath5k not working properly

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    9

    Default

    Hi, I have problems getting dhcp client to work with my BT4 install.

    The wireless card can be actviated using ifconfig wlan0 up. It can then scan (e.g. iwlist wlan0 scan, and can also listen to traffic using airmon-ng and airodump-ng and wireshark.)
    I can however not connect to a hotspot (I'm on vacaction and haven't been able to test a network with fixed IP).

    It goes something like this.

    Ifconfig wlan0 up
    Iwlist wlan0 scan
    Iwconfig wlan0 essid XX:XX:XX:XX:XX
    dhclient wlan0

    I get this error in from dhclient: wmaster0: unknown hardware address type 801 also it ends saying that no dhcp-server responded. (It does respjnd when I use Ubuntu on the same computer). Also the /var/log/messages says something about wlan0: link is not ready.

    Have someone else had this problem ? How should I try to resolve it ?

    Best Regard
    Selepo

    Code:
    >ifconfig
    wlan0     Link encap:Ethernet  HWaddr 00:0b:cd:5b:1a:3f  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    wmaster0  Link encap:UNSPEC  HWaddr 00-0B-CD-5B-1A-3F-00-00-00-00-00-00-00-00-00-00  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    >iwconfig
    wlan0     IEEE 802.11bg  ESSID:""  
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
              Tx-Power=27 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    >iwlist wlan0 scan
    wlan0     Scan completed :
              Cell 01 - Address: 00:13:60:E8:2B:70
                        ESSID:"homerun"
                        Mode:Master
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=57/100  Signal level:-73 dBm  Noise level=-93 dBm
                        Encryption key:off
                        IE: Unknown: 0007686F6D6572756E
                        IE: Unknown: 010482848B96
                        IE: Unknown: 030101
                        IE: Unknown: 2A0102
                        IE: Unknown: 851E000084001F00FF0301007374682D636C6172696F6E2D686F740000000025
                        IE: Unknown: DD180050F2020101040003A5000027A5000042545E0062432F00
                        IE: Unknown: DD1600409604000407A5000023A500004254000062430000
                        IE: Unknown: DD050040960302
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                        Extra:tsf=0000116e4dc3118f
                        Extra: Last beacon: 856ms ago
    In addition people seems to suggest that you should use NetworkManager, however i can't find it. I am using Pre Final BT4.

    Best Regards
    Selepo

    Code:
    >dhclient
    There is already a pid file *** with pid 5925
    killed old client process, removed PID file
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit 
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on ***
    Sending on   ***
    Sending on   Socket * fallback
    DHCPDISCOVER on wlan0 to *** port 67 interval 6
    DHCPDISCOVER on wlan0 to *** port 67 interval 15
    DHCPDISCOVER on wlan0 to *** port 67 interval 8
    DHCPDISCOVER on wlan0 to *** port 67 interval 9
    DHCPDISCOVER on wlan0 to *** port 67 interval 13
    DHCPDISCOVER on wlan0 to *** port 67 interval 10
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping

  2. #2
    Member alacrityathome's Avatar
    Join Date
    Jan 2010
    Posts
    248

    Default

    Wicd instead of Network Manager.

  3. #3
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    9

    Default Wicd

    Sure, but it only seems to go to the background. Where can I find something that will help me connect ? Is there a GUI ?

  4. #4
    Member alacrityathome's Avatar
    Join Date
    Jan 2010
    Posts
    248

    Default

    boot
    /etc/init.d/wicd start
    under internet choose wicd settings manager

  5. #5
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    9

    Unhappy Ok, but...

    Sorry, I was unclear. I can start wicd in menu or in a terminal window. However nothing happens. I see nothing on the screen... (There is no result from the action clicking on wicd).

    /Selepo

  6. #6
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    Airodump puts your wireless card into Monitor Mode and leaves it in Monitor Mode.

    Have you been putting your network card back into Managed Mode before trying to connect to an access point?

    Here's how you get Managed Mode:
    Code:
    airmon-ng stop wlan0
    After you do that, you can proceed with "iwconfig wlan0 essid blah blah blah"
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •