Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Problem with wicd

  1. #11
    Junior Member najib's Avatar
    Join Date
    Jul 2008
    Posts
    52

    Thumbs up

    Thank you MadDog for a 1st post that is THE post.

    /etc/init.d/wicd start
    or
    /etc/init.d/networking

    I can just add, and it's very important, if you want to retrieve your configuration after rebooting.

    update-rc.d wicd defaults
    or
    update-rc.d networking defaults

    NjB

  2. #12
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    1

    Default This is what I did

    I installed a copy of bt4 to my hard drive and earlier had it persistent on my usb drive.

    I run this on an Acer Aspire One d250 and got everything working .

    I had the same problem as in the post above and in order to fix it i had to do the following:

    For some reason BT4 pre starts up with my wlan0 wifi card in monitor mode. I actually like it like this since I can quickly open Kismet and such without any command mambo.

    to get wicd network manager working I would have to bring my wlan0 down from monitor mode. there are many ways to do it but the easiest for me is:

    as root...

    #airmon-ng stop wlan0

    then i bring up the networking and wicd with:

    #/etc/init.d/networking start

    #/etc/init.d/wicd start

    if you already have kde running you can now go to KMenu->Internet->Wicd Network Manager

    if you doc this before you startx then it will sit in ur taskbar.

    They key to this was taking the wlan0 or ath0 out of monitor mode which it starts in by default.

    Hope it helps...

    Love BT4 Pre...

  3. #13
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    2

    Default

    in Konsole,

    Code:
    update-rc.d wicd defaults
    Reboot. Job done. Enjoy .

  4. #14
    Yeeshkull
    Guest

    Default

    Quote Originally Posted by vvpalin View Post
    This is not an issue at all with wicd.

    boot
    /etc/init.d/wicd start
    under internet choose wicd settings manager


    Everything will be fine, you dont need to do all the other stuff if your using wicd.
    I tried this on BT3 after booting and signing on as root and toor and at the command prompt I typed "/etc/init.d/wicd start" and this were the results:

    -bash: /etc/init.d/wicd start: No such file or directory

    Please assist, thanks

  5. #15
    Senior Member
    Join Date
    Apr 2006
    Posts
    154

    Default

    Quote Originally Posted by h4x0r View Post
    if u asked me Tom Hurley then the answer is the following:
    eth1 (there r no problems)
    wlan0 (atheros -> Dlink DWG-650)
    i have still problems to connecting to WEP-wlans with wlan0. i cant use wicd....i set up all manually and connect manually. it's no problem cause i wrote a bash for all the wlan's.
    with WPA and wicd is no problem.
    i will post the log's for this issue this week.

    [Update]
    ok i'v tested it again. i did the following steps:
    Services->Network->Start Network
    Internet->wicd
    in wicd i choose a WEP encrypted one. No Connection. here the syslog:
    Jul 23 23:02:15 bt dhclient: Internet Systems Consortium DHCP Client V3.1.1
    Jul 23 23:02:15 bt dhclient: Copyright 2004-2008 Internet Systems Consortium.
    Jul 23 23:02:15 bt dhclient: All rights reserved.
    Jul 23 23:02:15 bt dhclient: For info, please visit http://www.isc.org/sw/dhcp/
    Jul 23 23:02:15 bt dhclient:
    Jul 23 23:02:15 bt dhclient: wmaster0: unknown hardware address type 801
    Jul 23 23:02:15 bt dhclient: wmaster0: unknown hardware address type 801
    Jul 23 23:02:15 bt dhclient: Bind socket to interface: No such device
    Jul 23 23:02:15 bt kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    Jul 23 23:02:16 bt kernel: wlan0: authenticate with AP XX:XX:XX:XX:XX:XX
    Jul 23 23:02:16 bt kernel: wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
    Jul 23 23:02:16 bt kernel: wlan0: authenticated
    Jul 23 23:02:16 bt kernel: wlan0: associate with AP XX:XX:XX:XX:XX:XX
    Jul 23 23:02:16 bt kernel: wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    Jul 23 23:02:16 bt kernel: wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate

    i looked what iwconfig says....it sets the essid but not the key (it is surly configured in wicd. i tried the diffrent options too)....
    wlan0 IEEE 802.11bg ESSID:"anAP"
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Encryption keyff
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    after them i tried succesfully to connect to a WPA.
    when i set the HEX-Key with iwconfig and do dhclient i can connect to the WEP encrypted ones.

    I have the same problem,have you found a valid solution?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •