Results 1 to 4 of 4

Thread: help, bt3 & alfa card, kismet error FATAL: Illegal card source line?

  1. #1
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    5

    Unhappy help, bt3 & alfa card, kismet error FATAL: Illegal card source line?

    Ok as some of you may have read in the other thread I just posted, after booting bt3 from usb drive, I was unable to use the 'startx' to start the gui, therefor it left me at the command prompt, so im not sure if this is one of the reasons for my below problem.

    I am new to linux and just starting to pen test my home wifi network. I was trying to follow along from the segment in a recent Hak5 episode from revision3.com. The hak5 episode was #518. They were using a "Alfa AWUS036H" WiFi Card to Pen Test a WiFi network with WPA. Well I order that exact "Alfa AWUS036H" card and that is what I am trying to use while having this problem here.

    In the episode they say type "airmon-ng start wlan0" to start the card or something. Now im not sure if this matters, but in the episode when they type that, there screen looks like this:

    Interface Chipset Driver
    wifi0 Atheros madwifi-ng
    wlan0 RTL8187 r8187 (monitor mode enabled)

    However, on my screen, when I type that same command, mine looks like this:

    Interface Chipset Driver
    wlan0 RTL8187 r8187 (monitor mode enabled)

    Mine is missing 1 item. Anyways on we go.

    Next they say type "kismet -c RT8180.wlan0.ALFA" to start kismet. Well on the episode, kismet starts right up for them, but on my screen it just says:
    "FATAL: Illegal card source line 'RT8180.wlan0.ALFA'"

    And if I try to run kismet by just typing "kismet", it says:
    "FATAL: Please configure at least one packet source".


    Can anyone take a second to explain to me what im doing wrong here? Could it have something todo with my other problem that I also posted another thread about where I cant start the gui using 'startx' and maybe that gui is needed to see my alfa wifi card? I have my alfa wifi card usb plugged into the laptop the whole time, even before I turn on the computer.

    Also can someone take another second and explain to me something about that command im trying to use, "kismet -c RT8180.wlan0.ALFA". In this command, where are they getting 'ALFA' from? Whats that for? I dont see that listed anywhere. Also where are they getting the "RT8180" from in that command? Shouldnt that be RT8187 or something? RT8180? The only place I see something similar to that is in that interface list from before, but that says RTL8187 or r8187.

    Anyways I extremely appreciate anyone taking the time to answer these 2 questions. Seriously!!!

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Please review the forum rules before making any further posts.

    Also this is probably the most commonly asked about error on the forums which leads me to belive you havent searched on single bit for your answer.

    So allow me to help: http://lmgtfy.com/?q=FATAL%3A+Please...+packet+source

  3. #3
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    5

    Default

    Quote Originally Posted by pureh@te View Post
    Please review the forum rules before making any further posts.

    Also this is probably the most commonly asked about error on the forums which leads me to belive you havent searched on single bit for your answer.

    So allow me to help: lmgtfy.com/?q=FATAL%3A+Please+configure+at+least+one+packet+s ource]Let me google that for you
    I actually have done a ton of searching to get to the point where im at, hours actually. And the search link you posted for "FATAL: Please configure at least one packet source", thats not the error im wondering about. My error was "FATAL: Illegal card source line 'RT8180.wlan0.ALFA'".

    Anyway forget that, my main question is with after typing "airmon-ng start wlan0" like shown in the segment, why does they're output have 2 items listed, and mine only have the 1? They have wifi0 and wlan0 and I only have wlan0, as I you can see with the charts I posted in my first post. My question is, because of my first problem not being able to load the gui, is bt3 not seeing my alfa wifi card or is there another reason mine looks different? Im using the exact Alfa AWUS036H WiFi Card they are using in the segment.

    I dont mean to be a pain, im just getting extremely frustrated with this. Anyone that can help in any way, seriously I appreciate it!

  4. #4
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    5

    Default

    Ok, finally got it working. So if anyone finds this thread by searching, heres what worked for me.

    Open up the console window and type "nano /usr/local/etc/kismet.conf". Once the window loads, scroll down until you find the line that looks like this "source=none,none,addone". Replace that with this "source=rt8180,wlan0,ALFA". Notice there is a "," seperating them, not a ".". Took me awhile to notice that, im not sure why they were using periods in the video segment, and why it worked for them on the command line, but this worked for me so hope this helps anyone in the future with a similar problem. Once your finished editing that line, you have to save and exit the file. From what I remember I think I pressed "ctrl+x" then hit the "y" for yes to save it. After that just type "kismet" at the console and it should open up fine.

    Now this source setting isnt for all cards. It worked for me using my Alfa AWUS036H. I read somewhere though that this should work for all Realtek 8180 based cards.

    Now once your in kismet, it took me a second to figure out why I couldnt move up and down in the list of access points to select one. Not sure if this is for everyone, but I had to push "s" first, then just select the option you prefer for how kismet lists the found access points. Now you'll be able to move up and down and once you are over the access point you want to view, just hit "enter". Also to get back to the list of access points, hit "ctrl+x". Then at first I couldnt figure out how to exit kismet and get back to the console, without just closing the window and re-opening another console. Then I figured out if you hit "ctrl+c", kismet will exit and bring you back to the console.

    Anyway maybe this info will help someone down the road...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •