Results 1 to 5 of 5

Thread: How to background a Meterpreter session?

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    10

    Default How to background a Meterpreter session?

    Target - XP Pro
    MSF listener - Ubuntu 9.04


    I have successfully created a meterpreter .exe that calls back to a listening msf meterpreter. With the
    Code:
     msf exploit(handler) > set ExitOnSession false
    option set, the listener does not go into interactive mode with the first session to connect.

    I can have multiple sessions listed

    Code:
    sessions -l
    The problem is I can not go into a session and back out of it without closing the connection.

    If I CRTL+C inside a session to background it, MSF asks me to type the exit command which ends the session.

    If I list all options from HELP there is no background option.

    I am running MSF 3.2 and created the .exe from 3.2 as well.

    How to I switch between sessions?

  2. #2
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default

    Quote Originally Posted by JamesN View Post
    Target - XP Pro
    MSF listener - Ubuntu 9.04


    I have successfully created a meterpreter .exe that calls back to a listening msf meterpreter. With the
    Code:
     msf exploit(handler) > set ExitOnSession false
    option set, the listener does not go into interactive mode with the first session to connect.

    I can have multiple sessions listed

    Code:
    sessions -l
    The problem is I can not go into a session and back out of it without closing the connection.

    If I CRTL+C inside a session to background it, MSF asks me to type the exit command which ends the session.

    If I list all options from HELP there is no background option.

    I am running MSF 3.2 and created the .exe from 3.2 as well.

    How to I switch between sessions?
    Type "sessions", the first or second option will give it away for you.

    Many of the metasploit commands are "available" within the meterpreter, it just doesn't always seem that way - try typing the correct command within your meterpreter session and see what happens.

    HTH
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    10

    Default

    I can see the sessiosn when I'm not in the session interactively.

    If I do a

    sessions -i 1

    and go into the session I can not get back out to list the other connected sessions. I can not background a session from within a interactive session.


    FYI

    the command

    sessions

    from within a interactive session yields a unknown command

  4. #4
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default

    Whoops yes I see what you mean, try ^Z (control + Z).

    Apologies for misleading you with my previous post.
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

  5. #5
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    10

    Default

    that works! Thankyou!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •