Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: AR5007 major problems

  1. #11
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    7

    Default

    That came from your first post.
    Lets again look at the basics
    Capital letters in linux are treated different then in windows.
    As such NetworkManager and networkmanager are two different beasts.
    # /etc/init.d/ networking start should be all you need.
    Slow down mate take your time and you will get there.

    Also why are you trying to install a a system wide driver out of a users home directory if you are working as root? If you configure to run this out of a users directory and you deleted the directory (or corrupt it) then you will no longer have the driver. Put it in the right place to begin with.
    I´ve tried /etc/init.d/networking start this is the output

    /etc/init.d/networking start
    Configuring network interfaces...Internet Systems Consortium DHCP Client V3.1.1


    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/eth0/00:1e:68:98:dd:c5
    Sending on LPF/eth0/00:1e:68:98:dd:c5
    Sending on Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    if-up.d/mountnfs[eth0]: waiting for interface eth1 before doing NFS mounts
    if-up.d/mountnfs[eth0]: waiting for interface eth2 before doing NFS mounts
    if-up.d/mountnfs[eth0]: waiting for interface ath0 before doing NFS mounts
    if-up.d/mountnfs[eth0]: waiting for interface wlan0 before doing NFS mounts
    eth1: ERROR while getting interface flags: No such device
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    ]

    wmaster0: unknown hardware address type 801
    SIOCSIFADDR: No such device
    eth1: ERROR while getting interface flags: No such device
    eth1: ERROR while getting interface flags: No such device
    wmaster0: unknown hardware address type 801
    Bind socket to interface: No such device
    Failed to bring up eth1.
    eth2: ERROR while getting interface flags: No such device
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.


    wmaster0: unknown hardware address type 801
    SIOCSIFADDR: No such device
    eth2: ERROR while getting interface flags: No such device
    eth2: ERROR while getting interface flags: No such device
    wmaster0: unknown hardware address type 801
    Bind socket to interface: No such device
    Failed to bring up eth2.
    ath0: ERROR while getting interface flags: No such device
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    ]

    wmaster0: unknown hardware address type 801
    SIOCSIFADDR: No such device
    ath0: ERROR while getting interface flags: No such device
    ath0: ERROR while getting interface flags: No such device
    wmaster0: unknown hardware address type 801
    Bind socket to interface: No such device
    Failed to bring up ath0.
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.


    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:22:69:06:38:6a
    Sending on LPF/wlan0/00:22:69:06:38:6a
    Sending on Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    if-up.d/mountnfs[wlan0]: waiting for interface eth1 before doing NFS mounts
    if-up.d/mountnfs[wlan0]: waiting for interface eth2 before doing NFS mounts
    if-up.d/mountnfs[wlan0]: waiting for interface ath0 before doing NFS mounts
    Also tried to connect via wire connection and also failed, doesn´t seem to recognise my card. Still really struggling with this issue.

  2. #12
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Ok let's look at some basics here.
    In order to find out if the card is recognized by the kernel then you should do a lspci or lsusb depending on the card type pci or usb.
    Once you find that the card is recognized by the kernel, then you can move forward, with configuration. Generally you would use ifconfig to list the current active interfaces. Of course you can change certain properties with this as well. Also iwconfig is used for wireless interfaces.

    The only reason I posted this is because I have not seen the output or reference to any of the above. I know the card works as I have one in one of my laptops and have had no problems with it.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #13
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    19

    Default

    hello, i upped the device wlan0, then did iwlist wlan0 scan, and it ses no networks are in range, but there are loads so for some reason its not finding any?

  4. #14
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    19

    Default

    ive done ifconfig and iwconfig, and it does recognise my card, everything seems to work as it should but it wont detect any networks. Also even if i plug in via ethernet i still cant get the internet. iwconfig shows ath0 and wifi0, so i up those and try both in monitor mode but still cant find any networks. I normally have to switch the wireless on in windows via fn + f1, but obv this wont work in backtrack, could that be the problem is there any way around this? thanks guys

  5. #15
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    19

    Default

    I assume that is what the problem is, that i cant switch the wireless on. In windows if the switch isnt on then no networks will show up but the card is still recognised so i guess this is the problem. Is there a command that will enable the device? sorry for double post

  6. #16
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    7

    Default

    Quote Originally Posted by archangel.amael View Post
    Ok let's look at some basics here.
    In order to find out if the card is recognized by the kernel then you should do a lspci or lsusb depending on the card type pci or usb.
    Once you find that the card is recognized by the kernel, then you can move forward, with configuration. Generally you would use ifconfig to list the current active interfaces. Of course you can change certain properties with this as well. Also iwconfig is used for wireless interfaces.

    The only reason I posted this is because I have not seen the output or reference to any of the above. I know the card works as I have one in one of my laptops and have had no problems with it.
    Here is my output from the above commands your help is much appreciated as I am a real newbie to all this.

    root@toaksie:~# lspci

    08:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

    09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
    There was obviously more output from lspci but I believe these are the important parts.


    root@toaksie:~# ifconfig ath0 up
    ath0: ERROR while getting interface flags: No such device

    root@toaksie:~# ifconfig eth0 up
    root@toaksie:~# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:1e:68:98:dd:c5
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:30 Base address:0x8000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    root@toaksie:~# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Encryption keyff
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    What is the next step in this little puzzle?

  7. #17
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default

    Enable the wireless card in the BIOS and reboot into backtrack. Or look for a hardware switch. My function keys work for both backtrack and windows on my Asus EEEPC with no modifications to backtrack, so at least for that model it seems to catch it before sending the data off to the OS. However if I have the wireless turned off when I boot and then turn it on, backtrack won't see it. This could be part of your problem cjloz.
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

  8. #18
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    19

    Default

    The card is on in the bios. I remember when i used to have ubuntu there was a command that made the card enabled, but i cant find it again now? There is no hardware switch its fn + f1 and it doesnt work in backtrack. So i wonder if anyone knows the command to enable it?

  9. #19
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Ok Let's try this one
    I am going to copy the info from another site below just for others who may need it. But the info comes from here.
    As another note I did not need to do this. Mine worked just fine as it is.

    So checkout new driver
    Code:
    svn checkout http://svn.madwifi-project.org/madwifi/branches/madwifi-hal-0.10.5.6/ madwifi-hal
    pushd madwifi-hal
    Injection support is optional. It’s very simple to achieve with the Aircrack-ng patch, however:
    Code:
    wget http://patches.aircrack-ng.org/madwifi-ng-r3745.patch -O – | patch -Np1
    Now the driver needs to be built. This requires that we have the kernel headers installed. On Ubuntu, it’s a simple matter of installing build-essential and linux-headers-generic (or whichever corresponds to the kernel in use). Then:
    Code:
       make clean && make
    Before we install the new driver, it’s best if we stop the wireless device first and unload the current driver:
    Code:
    sudo ifconfig ath0 down
    sudo ifconfig wifi0 down
    sudo ./scripts/madwifi-unload
    Now we can install the driver, which should start working without a reboot:
    Code:
     sudo make install
    sudo depmod -ae
    sudo modprobe ath_pci
    popd
    and we’re done. The files can be removed now, but it’s best that they be kept — the driver will need to be rebuilt and reinstalled whenever a new kernel is installed, like so:
    Code:
    pushd madwifi-hal
    make clean && make
    sudo ifconfig ath0 down
    sudo ifconfig wifi0 down
    sudo ./scripts/madwifi-unload
    sudo make install
    sudo depmod -ae
    sudo modprobe ath_pci
    popd

    Again this is more or less a cut and paste so all credits ( if it works goes to the author).

    There are several other links one can look at by using
    ar5007 in google with either madwifi, aircrack-ng or ubuntu or combos.
    As I also stated I did not have a need to try this out.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  10. #20
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    7

    Default

    Tried your below suggestions thought i was getting somewhere however the output from make install is as follows:

    root@toaksie:~/madwifi-hal# sudo make install
    Checking requirements... ok.
    Checking kernel configuration... ok.
    make -C /lib/modules/2.6.29.4/build SUBDIRS=/home/tom/madwifi-hal modules
    make[1]: Entering directory `/usr/src/linux-source-2.6.29.4'

    WARNING: Symbol version dump /usr/src/linux-source-2.6.29.4/Module.symvers
    is missing; modules will have no dependencies and modversions.

    Building modules, stage 2.
    MODPOST 14 modules
    make[1]: Leaving directory `/usr/src/linux-source-2.6.29.4'
    sh scripts/find-madwifi-modules.sh -r 2.6.29.4
    for i in ath/ ath_hal/ ath_rate/ net80211/; do \
    make -C $i install || exit 1; \
    done
    make[1]: Entering directory `/home/tom/madwifi-hal/ath'
    test -d //lib/modules/2.6.29.4/net || mkdir -p //lib/modules/2.6.29.4/net
    install -m 0644 ath_pci.ko //lib/modules/2.6.29.4/net
    make[1]: Leaving directory `/home/tom/madwifi-hal/ath'
    make[1]: Entering directory `/home/tom/madwifi-hal/ath_hal'
    test -d //lib/modules/2.6.29.4/net || mkdir -p //lib/modules/2.6.29.4/net
    install -m 0644 ath_hal.ko //lib/modules/2.6.29.4/net
    make[1]: Leaving directory `/home/tom/madwifi-hal/ath_hal'
    make[1]: Entering directory `/home/tom/madwifi-hal/ath_rate'
    for i in amrr/ onoe/ sample/ minstrel/; do \
    make -C $i install || exit 1; \
    done
    make[2]: Entering directory `/home/tom/madwifi-hal/ath_rate/amrr'
    test -d //lib/modules/2.6.29.4/net || mkdir -p //lib/modules/2.6.29.4/net
    install -m 0644 ath_rate_amrr.ko //lib/modules/2.6.29.4/net
    make[2]: Leaving directory `/home/tom/madwifi-hal/ath_rate/amrr'
    make[2]: Entering directory `/home/tom/madwifi-hal/ath_rate/onoe'
    test -d //lib/modules/2.6.29.4/net || mkdir -p //lib/modules/2.6.29.4/net
    install -m 0644 ath_rate_onoe.ko //lib/modules/2.6.29.4/net
    make[2]: Leaving directory `/home/tom/madwifi-hal/ath_rate/onoe'
    make[2]: Entering directory `/home/tom/madwifi-hal/ath_rate/sample'
    test -d //lib/modules/2.6.29.4/net || mkdir -p //lib/modules/2.6.29.4/net
    install -m 0644 ath_rate_sample.ko //lib/modules/2.6.29.4/net
    make[2]: Leaving directory `/home/tom/madwifi-hal/ath_rate/sample'
    make[2]: Entering directory `/home/tom/madwifi-hal/ath_rate/minstrel'
    test -d //lib/modules/2.6.29.4/net || mkdir -p //lib/modules/2.6.29.4/net
    install -m 0644 ath_rate_minstrel.ko //lib/modules/2.6.29.4/net
    make[2]: Leaving directory `/home/tom/madwifi-hal/ath_rate/minstrel'
    make[1]: Leaving directory `/home/tom/madwifi-hal/ath_rate'
    make[1]: Entering directory `/home/tom/madwifi-hal/net80211'
    test -d //lib/modules/2.6.29.4/net || mkdir -p //lib/modules/2.6.29.4/net
    for i in wlan.o wlan_wep.o wlan_tkip.o wlan_ccmp.o wlan_acl.o wlan_xauth.o wlan_scan_sta.o wlan_scan_ap.o; do \
    f=`basename $i .o`; \
    install -m 0644 $f.ko //lib/modules/2.6.29.4/net; \
    done
    make[1]: Leaving directory `/home/tom/madwifi-hal/net80211'
    (export KMODPATH=/lib/modules/2.6.29.4/net; /sbin/depmod -ae 2.6.29.4)
    make -C ./tools all || exit 1
    make[1]: Entering directory `/home/tom/madwifi-hal/tools'
    for d in ath_info; do \
    make -C $d || exit 1; \
    done
    make[2]: Entering directory `/home/tom/madwifi-hal/tools/ath_info'
    make[2]: Nothing to be done for `all'.
    make[2]: Leaving directory `/home/tom/madwifi-hal/tools/ath_info'
    make[1]: Leaving directory `/home/tom/madwifi-hal/tools'
    make -C ./tools install || exit 1
    make[1]: Entering directory `/home/tom/madwifi-hal/tools'
    for d in ath_info; do \
    make -C $d || exit 1; \
    done
    make[2]: Entering directory `/home/tom/madwifi-hal/tools/ath_info'
    make[2]: Nothing to be done for `all'.
    make[2]: Leaving directory `/home/tom/madwifi-hal/tools/ath_info'
    install -d /usr/local/bin
    for i in athstats 80211stats athkey athchans athctrl athdebug 80211debug wlanconfig wpakey; do \
    install $i /usr/local/bin/$i; \
    strip /usr/local/bin/$i; \
    done
    install -d /usr/local/man/man8
    install -m 0644 man/*.8 /usr/local/man/man8
    install ../scripts/madwifi-unload /usr/local/bin/madwifi-unload
    for d in ath_info; do \
    make -C $d install || exit 1; \
    done
    make[2]: Entering directory `/home/tom/madwifi-hal/tools/ath_info'
    install -d /usr/local/bin
    install -m 755 ath_info /usr/local/bin
    install -d /usr/local/share/man/man8
    install -m 644 ath_info.8 /usr/local/share/man/man8
    make[2]: Leaving directory `/home/tom/madwifi-hal/tools/ath_info'
    make[1]: Leaving directory `/home/tom/madwifi-hal/tools'
    The highlighted line I believe tells me something I'm just not sure what, after following all the instructions my ifconfig still looks like this

    root@toaksie:~/madwifi-hal# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:1e:68:98:dd:c5
    inet addr:192.168.1.131 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::21e:68ff:fe98:ddc5/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:7785 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5826 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:10343868 (10.3 MB) TX bytes:645404 (645.4 KB)
    Interrupt:30 Base address:0x8000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:42 errors:0 dropped:0 overruns:0 frame:0
    TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2100 (2.1 KB) TX bytes:2100 (2.1 KB)

    wlan0 Link encap:Ethernet HWaddr 00:22:69:06:38:6a
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    wmaster0 Link encap:UNSPEC HWaddr 00-22-69-06-38-6A-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    it does seem to see my wifi cards correct hardware address but finds no wireless points eith from iwlist wlan0 scan or through Wicd Manager

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •