Results 1 to 3 of 3

Thread: bluetooth questo sconosciuto

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    10

    Default bluetooth questo sconosciuto

    ciao a tutti..
    che bella la bt4pF e il forum in it ancor di piu'
    cmq
    ci sarebbe un problema con il bluetooth
    non riesco a ricevere i dati dall'antenna gps.
    all'inizio non mi riconosceva neanche il device ma dopo un po di prove..
    ----------------------------------------------
    root@linus-bt:~# /etc/init.d/bluetooth restart
    Stopping bluetooth: bluetoothd.
    Starting bluetooth: bluetoothd.

    root@linus-bt:~# rfcomm
    rfcomm0: xx:xx:xx:xx:xx:xx channel 1 clean [attack tty]

    root@linus-bt:~# hcitool cc xx:xx:xx:xx:xx:xx 1

    root@linus-bt:~# hcitool con
    Connections:
    < ACL xx:xx:xx:xx:xx:xx handle 0 state 5 lm MASTER

    il dump ci da:
    ----------------
    root@linus-bt:~# hcidump hci0
    HCI sniffer - Bluetooth packet analyzer ver 1.42
    device: hci0 snap_len: 1028 filter: 0xffffffff
    < HCI Command: Create Connection (0x01|0x0005) plen 13
    > HCI Event: Command Status (0x0f) plen 4
    > HCI Event: Connect Complete (0x03) plen 11
    < HCI Command: Read Remote Supported Features (0x01|0x001b) plen 2
    > HCI Event: Command Status (0x0f) plen 4
    > HCI Event: Page Scan Repetition Mode Change (0x20) plen 7
    > HCI Event: Max Slots Change (0x1b) plen 3
    < HCI Command: Remote Name Request (0x01|0x0019) plen 10
    > HCI Event: Command Status (0x0f) plen 4
    > HCI Event: Connection Packet Type Changed (0x1d) plen 5
    > HCI Event: Read Remote Supported Features (0x0b) plen 11
    > HCI Event: Remote Name Req Complete (0x07) plen 255
    < HCI Command: Disconnect (0x01|0x0006) plen 3
    > HCI Event: Command Status (0x0f) plen 4
    > HCI Event: Disconn Complete (0x05) plen 4
    ecc. ecc. sempre uguale....
    ------------------------------
    e quindi non si riceve niente.

    poi cercando con google....
    mi porta ad un bug sia in ubuntu che debian (manca il demone hcid e naturalmente hcid.conf.)
    ...poi..lo stack bluez č cambiato, ((rispetto alla bt3 slax) non piu' hcid.conf ma passkey-agent )ecco perche' alcuni comandi che file di configurazione mancano!!
    ma continuando a cercare avevo trovato in un forum che qualcuno aveva risolto con un pakketto di debian dove il bug č stato corretto ma non sono piu riuscito a ritrovare il link, cmq. qualche consiglio?
    qualcuno ha risolto..? e mi puo aiutare?
    tnks to all
    -= l1no =-

  2. #2
    Junior Member keeley's Avatar
    Join Date
    Jun 2009
    Posts
    67

    Default

    prova cosė_

    prima avvi il servizio bluetooth come hai fatto tu.
    poi fai hcitool scan con chiavetta attaccata e dispositivo bluetooth attivo.

    dovrebbe trovartelo.

    Segui questa guida ma dal "hcitool scan" in poi, la parte precedente ignorala

    ww.michelem.org/2007/08/01/usare-linux-come-navigatore-gps-con-ubuntu-e-gpsdrive-un-tomtom-free/

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    10

    Default

    Quote Originally Posted by keeley View Post
    prova cosė_
    -------------
    dovrebbe trovartelo.
    Segui questa guida ma dal "hcitool scan" in poi, la parte precedente ignorala

    xxx.michelem.org/2007/08/01/usare-linux-come-navigatore-gps-con-ubuntu-e-gpsdrive-un-tomtom-free/
    forse non sono riuscito a spiegarmi..colpa mia... il device lo trova senza problemi, e si associa come puoi vedere sul mio post. la connessione č stabilita; ma non ricevo....nada
    la guida che mi consigli la conosco ma non serve non vanno bene bluezpin e bluez-utils con il nuovo kernel.
    che ha ora la BT4pF.
    cmq tnks a lot
    -= l1no =-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •