Results 1 to 4 of 4

Thread: 'Error Loading Operating System' When booting BT4

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    May 2009
    Posts
    4

    Default 'Error Loading Operating System' When booting BT4

    Hi

    I have 2 hard drives on my machine, one with BT4 and the other was empty, until recently decided to put windows on it, so, I unplugged the first hard drive (the one with BT4 on it) and set the empty drive as the first HDD, after successfully installing and booting windows on the empty drive, I plugged in the BT4 HDD (as the first HDD now) and got the error 'Error Loading Operating System'.
    I tried booting into an ubuntu live CD (just one I had on hand) and can see all the files on the filesystem for backtrack (Except the files in root?)

    I'm not sure what to do? Any advice?

  2. #2
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    Is it your BIOS that is giving that error? If so you probably need to use a boot CD to play around with your partition table, you might need to set the master boot record and also set the boot flag on the appropriate partition.
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

  3. #3
    Just burned his ISO
    Join Date
    May 2009
    Posts
    4

    Default

    Hi

    This is my the current partition settings:

    hxxp://img363.imageshack.us/img363/2312/screenshotdevsdagparted.png

    [Can't link yet]

    Also, not sure if this is of any importance, but when I tried to boot the backtrack live CD, I got the error:
    Kernel Panic
    Not Syncing: VFS: Unable to mount root FS on unknown-block(hd0,0)
    Also, normally when I'm booting off grub, the command is:
    kernel (hd0,0)/vmlinuz root=/dev/sda3

    Thanks

    EDIT: Have decided might as well just go to BT4-PreFinal, but is there any way I can retrieve the files contained in the root folder? For some reason I cannot see them using the live cd (Can see the folder and go inside it, but cannot see any files present)

    EDIT2: Sorry, have just realized that this is in the wrong section, I'm using BT4-Beta, feel free to move the thread.

    EDIT3: Just did enable show hidden folders in /root and there's 3 files in there? Not sure what that means. [Files are: .wapi, .bashrc and .profile.

    Also could it be anything to do with bootloader[s]?
    In the /boot folder I have:
    abi-2.6.22-14-generic
    config-2.6.22-14-generic
    initrd.img-2.6.22-14-generic.bak
    memtest86+.bin
    System.map-2.6.22-14-generic
    vmlinuz-2.5.22-14-generic

  4. #4
    Just burned his ISO
    Join Date
    May 2009
    Posts
    4

    Default

    Sorry,

    Have just booted it into BT4, but still no files? I cannot see any of my original files that resided in root, also some of the software I installed is not present.

    Any way to recover the data?

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •